After performing an upgrade from Natty to Oneiric, I had a problem similar to the one reported in here at every system boot: Desktop forgets theme?

Everything, from the LigthDM greeter to the ubuntu desktop used the ugly raleigh theme, apart from firefox, thunderbird few other applications after logging in.

Unfortunately none of the solutions suggested in the topic above worked for me. The only way I could get acceptable appearance would be to switch to gnome at login and using the Adwaita theme. The lightdm greeter still uses the raleigh theme though.

Unfortunately, I tried some "brute-force" methods by reinstalling (sudo apt-get install --reinstall) ubuntu-desktop, unity, unity-common, unity-greeter, gnome-session, gtk2-engines. I also tried moving .config, .gconf, .gconfd, .gnome, .gnome2 to a backup dir to reset account desktop preferences. None of the above solved the issue. On the contrary, logging-in to Ubuntu setup does not show unity and window decorations anymore.

My fallback remains the Gnome logon and the Adwaita theme.

This is my workstation machine I am hosting Ubuntu on, so, though possible, it is time consuming to perform a backup and format-reinstall ubuntu 11.10. Could you please let me know if I can get an alternative way of repairing my ubuntu desktop?

(I believe it all started when, during the 11.04-to-11.10 upgrade, the installation of downloaded packages for oneiric broke when nautilus-dropbox failed to access the dropbox servers - I am behind a proxy but with proper proxy settings had no problems using apt-get & synaptic. However I removed dropbox and resumed partial installation on second boot.)

  • Great detail and explanation. Deserves more upvotes. – Thomas Boxley Dec 31 '11 at 1:51

Install dconf-editor Install dconf-editor if you don't have it, and then go to


and check "active." One thing I've also noticed when this happens is that the media keys stop working: enable org.gnome.settings-daemon.plugins.media keys. There also might be some more plugins you should enable.

  • 1
    the package dconf-editor doesn't exist, but dconf-tools does and it seems to have a program called dconf-editor – Richard Hansen Feb 14 '12 at 0:43
  • How did you figure this out? Is there a bug report for this problem? – Richard Hansen Feb 14 '12 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.