2

I have a fresh installation of ubuntu gnome 15.10 and I cannot get bumblebee optirun to work. My laptop has the optimus setup with Intel and Nvidia graphics cards. I get the following error trying to use optirun:

~$optirun firefox
[ 4580.965189] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] KMS not enabled

[ 4580.965358] [ERROR]Aborting because fallback start is disabled.

I thought KMS was enabled by default with newer kernels but I'm not certain of this. Do I need to use bbswitch first?

0

Remove bumblebee and use nvidia-prime to switch between the two graphics solutions instead.

First identify your NVIDIA graphics hardware - open a terminal and execute:

lspci -k | grep -EA2 'VGA|3D'  

Search for available drivers on the NVIDIA Drivers website.

Update :

Uninstall every NVIDIA related software ...

When the GRUB boot menu appears : Highlight the Ubuntu menu entry and press the E key.
Add the nouveau.modeset=0 parameter to the end of the linux line ... Then press F10 to boot.

When the login screen appears press Ctrl+Alt+F1.

Enter user name and password - then execute :

sudo apt-get purge nvidia* bumblebee  
sudo reboot  

Update :

Install the latest stable NVIDIA drivers ...

When the GRUB boot menu appears : Highlight the Ubuntu menu entry and press the E key.
Add the nouveau.modeset=0 parameter to the end of the linux line ... Then press F10 to boot.

When the login screen appears press Ctrl+Alt+F1.

Enter user name and password - then execute :

sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo reboot  

Use the NVIDIA X Server Settings application (Prime Profiles) to switch between the two GPU's.

  • Yes, I am a new user to this group. I did follow the instructions above and my desktop has now completely failed. I'm hoping I don't have to reinstall everything, I was really in love with it. – user3174452 Nov 24 '15 at 15:22
  • @user3174452 What graphics card do you have and which drivers did you install ? – cl-netbox Nov 24 '15 at 15:33
  • It's an nvidia geforce 840m card and I installed the nvidia-358* driver I believe. – user3174452 Nov 24 '15 at 15:38
  • @user3174452 There must have been something going wrong with the installation process ... I will update the answer with an alternative way to install and include the latest long-lived branch drivers ... please stay tuned - it will take a few minutes. :) – cl-netbox Nov 24 '15 at 15:46
  • Do you not recommend purging nouveau? I would prefer not to. – user3174452 Nov 25 '15 at 0:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.