7

I have recently attempted to install mupen64plus on my Lubuntu machine. After doing this command:

sudo apt-get install mupen64plus

the install proceeds without error and everything sets up ok. But after I run the program, I get an error message about libpng16.so.16 not being present on the system. After doing a complete search of the file system, I could not find the shared library anywhere. So, is there a package or source repo where I can install this MIA shared library file into /usr/share/lib? After doing several Google searches of my own, I could not find anything to the effect. As far as I can tell, nobody has had this issue, or so few have had it that Google can't find anything about it.

5
  • Where have you the package from?
    – frlan
    Nov 22, 2015 at 20:20
  • I suppose you mean installed the package from? If so, I installed mupen64plus as described in the question. I did not download a third-party package, I let apt-get do the job itself.
    – nkeck72
    Nov 22, 2015 at 20:22
  • 1
    This sounds more like an bug and should be reported to launchpad as it appears that an Ubuntu package is having a dependency which cannot be solved.
    – frlan
    Nov 23, 2015 at 17:46
  • If you will look at the answer below, this solves the issue. The package was not installed when I installed Lubuntu.
    – nkeck72
    Nov 23, 2015 at 21:26
  • 1
    @nkeck72 Looking from your answer, the ldconfig trigger is missing in the package, which appears to be required. So the point is still valid, report it as a bug. A user should not have to worry about ldconfig, really. :-)
    – gertvdijk
    Nov 25, 2015 at 18:49

3 Answers 3

6

Try installing the libpng-libary Version 16:

sudo apt-get install libpng16-16
4

I have found the answer to this issue, there is a source repo on Sourceforge: https://sourceforge.net/projects/libpng/?source=directory The trick when you install the shared object is when you have it installed, you have to run

ldconfig

before the system sees it.

1

You may download the library manually from the link https://sourceforge.net/projects/libpng/?source=directory

It will download a file something like "libpng-1.6.32.tar.xz"

Simply extract the file and find a INSTALL file for instructions to install the library.

./configure
make check
make install

Then you need to run

ldconfig

Hope this will work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.