1

I tryed to install wine 1.6 from terminal but I always have this error, can someone help me??

giovanni@giovanni-X551CAP:~$ sudo apt-get install wine1.6
Reading package lists... Done
Building dependency tree... 50%
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.6 : Depends: wine1.6-amd64 (= 1:1.6.2-0ubuntu4)
           Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu4)
           Recommends: winbind but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt-get install wine1.6-amd64 wine1.6-i386

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.6-i386:i386 : Depends: libgphoto2-6:i386 (>= 2.5.2) but it is not going to be installed
                     Depends: libgphoto2-port10:i386 (>= 2.5.2) but it is not going to be installed
                     Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                     Recommends: libosmesa6:i386 but it is not going to be installed
                     Recommends: libsane:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

uname -a; lsb_release -a; apt-cache policy wine1.6

Linux giovanni-X551CAP 3.19.0-30-generic #34~14.04.1-Ubuntu SMP Fri Oct 2 22:09:39 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:    14.04
Codename:   trusty
wine1.6:
  Installed: (none)
  Candidate: 1:1.6.2-0ubuntu4
  Version table:
     1:1.6.2-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
  • Have you followed this : askubuntu.com/questions/140246/… ? – r3zaxd1 Nov 22 '15 at 16:33
  • Edit your question and add the output of uname -a; lsb_release -a; apt-cache policy wine1.6 – A.B. Nov 22 '15 at 16:54
  • post edited and this is the first time, i haven't open other questions – Giovanni Giampaolo Nov 22 '15 at 17:14
  • I follow the link given by r3zaxd1 but the error is still the same – Giovanni Giampaolo Nov 22 '15 at 17:25
  • also using sudo apt-add-repository main doesen't work – Giovanni Giampaolo Nov 22 '15 at 17:28
1

You have a break in your the dependency chain. Why? That's why:

apt-cache policy libgphoto2-6:i386 libgphoto2-6 gives

libgphoto2-6:i386:
  Installed: (none)
  Candidate: 2.5.3.1-1ubuntu2
  Version table:
     2.5.3.1-1ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
libgphoto2-6:
  Installed: 2.5.3.1-1ubuntu2.2
  Candidate: 2.5.3.1-1ubuntu2.2
  Version table:
 *** 2.5.3.1-1ubuntu2.2 0
        100 /var/lib/dpkg/status
     2.5.3.1-1ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

As you can see, you have only one installation candidate for libgphoto2-6:i386 with the version 2.5.3.1-1ubuntu2. But the version of libgphoto2-6:i386 have to be exact the same as for libgphoto2-6 and this is 2.5.3.1-1ubuntu2.2 not version 2.5.3.1-1ubuntu2. Correct with

sudo apt-get install libgphoto2-6=2.5.3.1-1ubuntu2 
sudo apt-get install -f

Earlier you had enabled trusty-updates, this channel contains the version 2.5.3.1-1ubuntu2.2 for both packages. You could also re-enable trusty-updates.

Open Software & Updates and the tab Updates and activate trusty-updates as you can see in the screenshot (ok, it's a Wily screenshot and not Trusty).

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.