1

Hi!

Before I begin describing the issue, let me mention that I tried following numerous suggestions,mostly revolving around disabling n mode and other options, as described in this one: Wifi losing connection, weak signal, Intel 7260 adapter

...and many others. Sadly it doesn't seem to help.

So I use Intel NUC5i3RYK. The wifi connection does not really disconnect, I can constantly see that it is connected (judging from the icon at least), but it just keeps being unstable: from time to time (like 2 times in every 5 minutes) the internet simply stops working - Skype and jabber (I use Pidgin) disconnect, I can't load any page etc. Then it comes back and the the circle starts over.

This is not a general issue with my WiFi itself, because I do not experience these issues on Windows or my Android mobile devices.

Details of the device:

02:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59) Subsystem: Intel Corporation Dual Band Wireless-AC 7265 [8086:9010] Kernel driver in use: iwlwifi

What else can I possibly do to solve it?

Thanks!

2
  • Please edit your question to add details of your wireless device: lspci -nnk | grep 0280 -A2 Also, on my NUC, many minor issues were solved when I updated the BIOS to the latest available. I recommend it if not already done.
    – chili555
    Nov 23, 2015 at 15:31
  • Hi @chili555, as you requested I added the device specs. Also my BIOS is in the latest version, I updated it after I bought the device and started and started encountering issues. Thanks for your response!
    – Kosimus
    Dec 1, 2015 at 19:47

1 Answer 1

1

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

Next, I am interested in which firmware version is being loaded. Reboot and run:

dmesg | grep iwl

Post the results that relate to firmware.

It appears that the driver finds and loads the -13 firmware but would use the later -14 or -15 if available. With a working internet connection, please do:

sudo apt-get update
sudo apt-get install git
git clone https://github.com/OpenELEC/iwlwifi-firmware.git
cd linux-firmware/firmware
sudo cp iwlwifi-7265D-14.ucode  /lib/firmware
sudo cp iwlwifi-7265D-15.ucode  /lib/firmware

Reboot and check:

dmesg | grep firmware

Ideally, the -15 firmware is loaded and performance is greatly improved.

14
  • I followed your suggestions and I can see an improvement. Thank you :). What I did: Security setting is 'WPA2 (CCMP)', which I think is OK. I set the channel to 6 (was auto before). Don't think I can set frequency to 20MHz (no such option). I can set WLAN type - I can choose from 802.11 n+g+b, n+g and b+g. I kept n+g+b. Then I did the iw reg set, as suggested (was indeed 00). Changed to DE as I live in Germany. Worked just fine, so I set it permanently. Afterwards I also switched IPv6 to be ignored for wifi.
    – Kosimus
    Dec 5, 2015 at 12:10
  • After a router reboot I used the dmesg | grep iwl command. Will post the outcome in separate comments, as it won't fit into a single one.
    – Kosimus
    Dec 5, 2015 at 12:11
  • [ 6.884491] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002) [ 6.887379] iwlwifi 0000:02:00.0: Unsupported splx structure [ 6.893701] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-15.ucode failed with error -2 [ 6.894691] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-14.ucode failed with error -2 [ 6.915548] iwlwifi 0000:02:00.0: loaded firmware version 25.30.13.0 op_mode iwlmvm [ 6.948476] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
    – Kosimus
    Dec 5, 2015 at 12:11
  • [ 6.949479] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 6.950078] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 7.036744] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs' [ 7.829387] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 7.830154] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 7.891571] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 7.892016] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
    – Kosimus
    Dec 5, 2015 at 12:11
  • [ 119.970245] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 119.970809] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 120.033451] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled [ 120.033896] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
    – Kosimus
    Dec 5, 2015 at 12:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .