0

I am running a x64bit laptop with Ubuntu 14.04(trusty tahr). I am wanting to install the PCSX2 emulator, to run my PS2 rom-game. I have tried countless things to make this work, but to no success.

Repository: ppa:gregory-hainaut/pcsx2.official.ppa

Input: sudo apt-get install pcsx2-unstable

Output: http://pastebin.com/fLCaLweY

I have no idea how I am going to fix this. Can someone please help?

Thank you.

P.S: If there's anything I can post here, that will help you guys 'solve this', please just let me know and I'll provide it.

0

Try using

$sudo apt-get autoremove

$sudo apt-get update

$sudo apt-get upgrade

$sudo apt-get -f install

This will use apt-get to try to find and fix any unmet dependencies this works in most cases. If apt-get still can not get the needed dependencies you might have to go and find them manually.

Also you always need to run a sudo apt-get update and upgrade after adding a ppa. Did you do this? Let me know if this still doesn't fix it. I can try it out in a virtual machine later.

  • I used 'sudo apt-get update', and it returns with this. pastebin.com/84TztrSQ :/ – Garlotch Nov 22 '15 at 10:07
  • Ok, never mind, I fixed that last thing. My original problem still remains though, even after your codes (that I tried). – Garlotch Nov 22 '15 at 10:28
0

PCSX2 can only be compiled for 32bit processors, but you are using 64bit system. PCSX2 requires some 32bit libraries to be installed, but since they would probably need to replace 64bit ones that are needed on your system, it throws error.

There are generally 3 ways how to install PCSX2 on Linux.

  1. Try to install 32bit libraries on 64bit system

    This is what you tried to do. It works for some people, but it never worked for me since I always needed some 64bit library that couldn't be installed together with it's 32bit version.

  2. Install PCSX2 in 32bit chroot on your 64bit system

    This is the cleanest solution since it doesn't pollute your 64bit system with 32bit libraries. This will in very simple words install 32bit system to a folder on your 64bit system, and any application that will be run from there will use 32bit libraries. This cleanly separates 64bit and 32bit system, so there are not any conflicts.

    Another good thing is that chroot is not emulation, so there is not any noticeable slowdown.

    If you are interested, here is link to my how-to that was created when I had the same problem. https://jirka642.wordpress.com/2016/02/04/installing-pcsx2-on-64bit-linux/

  3. Reinstall and use 32bit Linux

    You should probably only try this if everything else fails, since who wants to use 32bit system on modern PC?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.