0

I try to install ubuntu 15.04 in a Win 8.1 machine in uefi mode for dual boot. When I tried, installation stops saying "cannot install grub into sda, fatal error". and quits installation. I had created uefi ubuntu 15.04 using rufus from ubuntu amd64.iso. Also booted using USB created using Rufus. But the installation always stops saying the above error. EFI partition is already there. SDA is HDD (500GB).

0

First, you should be aware of boot mode issues. The vast majority of systems that shipped with Windows 8 or later boot Windows in EFI/UEFI mode. This configuration makes a BIOS/CSM/legacy-mode install of Ubuntu iffy at best. Unfortunately, a lot of BAD instructions tell people to enable their Compatibility Support Modules (CSMs; aka "legacy mode support" or something similar) as a routine part of installing Linux. This just complicates matters and creates problems, perhaps including the one you encountered. You can check your boot mode in the installer by dropping to a shell and looking for a directory called /sys/firmware/efi. If it's present, you've booted in EFI mode; if not, you've booted in BIOS mode. Be sure you're in EFI mode. (Assuming, of course, that Windows is in EFI mode. If you're not sure, check your partition table type. If it's GPT, Windows is booting in EFI mode. See here for more details.)

Second, it's imperative that you disable the Windows feature called Fast Startup (or various other things), as described here, among other places. This feature turns a shutdown operation into a suspend-to-disk operation, which makes it impossible to safely share partitions between OSes. As EFI boot loaders are stored on a shared FAT partition called the EFI System Partition (ESP), a failure to disable Fast Startup can cause problems when accessing the ESP and therefore a failure to successfully write GRUB. Note that there's a firmware feature that often has a name like "fast boot" that's often confused with the Windows Fast Startup feature. The firmware feature is irrelevant to this discussion. If you've disabled the firmware feature, you must still disable the Windows feature.

Third, more information is needed to fully diagnose the problem. Running the Boot Info Script will gather a lot of data and put it in a file called RESULTS.txt. You can study this file yourself or post it to a pastebin site and post the URL to your document here. We can then study it for clues about what's wrong.

Fourth, as a workaround, you can try using the USB flash drive or CD-R version of my rEFInd boot manager. Prepare the boot medium and boot using it. (You may need to disable Secure Boot if it's enabled.) rEFInd should give you the option to boot either Windows or Ubuntu. If you can boot Ubuntu with rEFInd, you can then work on fixing the boot loader problem. Maybe doing a dosfsck on the ESP would help; or you can run grub-install manually and see what sort of error messages it reports; or you can install rEFInd to your hard disk by using its PPA or Debian package. Depending on the cause, any of these actions, or various others, might help. In the meantime, you can continue using rEFInd on the external medium to boot, rather than re-install or muck about with the Ubuntu live CD, which is more limiting than the full installation.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.