I'm currently having a lot of trouble installing Ubuntu 14.04.3 alongside Windows 10 on my new Dell XPS 8900. I've downloaded the 14.04.3 iso and created a bootable usb from the iso. I've even double checked that there aren't any issues with the iso by matching the MD5 checksum. Right now my steps are:

1) Install Windows 10 on a 200 GB partition 2) Creating a EXT4 partition (790 GB) 3) Creating a Swap partition (8 GB) 4) Installing Ubuntu 14.04.3 on the two newly created partitions

However, each time I go through the Ubuntu installation I get two errors. First is a "This computer has only 0 bytes disk space remaining" and the second is a "Installer Crashed" which follows with attempting to send a bug report. The installer usually crashes at the step when it is adjust timezones. I've tried various different things like creating the partitions on GParted when I enter "try ubuntu" and just creating the partitions in the "do something else" step during the installation phase. Also another unusual thing that is happening is that within "try ubuntu" I do not seem to be able to run the "Install Ubuntu 14.04.3 LTS" shortcut. None of these things are working and I have been trying to search on-line for a solution but can't seem to find any resources. Does anyone have any advice?

  • Did you flag the ext4 partition as / ? – Raphael Nov 21 '15 at 1:36
  • Yes I did flag the ext4 partition as "/" – Geoff Nov 21 '15 at 1:45
  • You still should have Windows fast start up off. UEFI fast boot off and then use Something Else to choose the ext4 partition your created. If nVidia you probably need nomodeset. But if dual video you may need an Intel parameter. If new Skylake processor you need at least 15.10 and may need 16.04 or all the kernels & drivers that will be standard but only now in ppa for installing (testing) in 15.10. ubuntuforums.org/showthread.php?t=2292521 – oldfred Dec 5 '15 at 5:03

I met similar issues with you and finally I found a helpful post.

We should disable “PCI power management” to fix PCIe Bus error. Below is the steps I followed from that post:

When trying to install, at the initial 'grub' screen that asks you to select (1) Try Ubuntu (2) Install directly (3) OEM install etc. Place the selector over option 1 and press the key E to edit the grub boot command. On the third line just after quiet splash, add a space and the string pcie_aspm=off and press F10 to continue the boot. This will allow you to start 15.10 from a USB/DVD and install to disk.

That just installs to disk. You will have to manually update the Grub boot command every time you boot into Linux until you implement the fix in the grub config file. For this edit /etc/default/grub using your favourite editor and make sure the follow line is present:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=off"

This file is a “script that generates a script” so you have to run sudo update-grub to propagate this to the real Grub config files (/boot/grub/grub.cfg).

Finally I got this link helpful: http://ubuntuforums.org/showthread.php?t=2303880.

The root case is that 14.03 is not able to support new hardwares. I reinstalled with 15.10 and set 'pcie_aspm=off' during installation, problem resolved.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.