I am trying to connect my Xubuntu laptop to Motorola Arris surfboard sbg6782AC router. Previously I couldn't see any networks, but thanks to the help from AskUbuntu ( No wifi with N1525 or external netgear A6210 ) I am now able to connect to iphone hotspot and unencrypted Motorola router. However, I still cannot connect to my encrypted home network. It seems like an encryption standards mismatch. Motorola router has the following wireless security options: WPA2-PSK, WPA2-PSK+WPA-PSK, unencrypted, WPA-PSK, WPA(enterprise) WPA2+WPA(Enterprise). Meanwhile Xubuntu offers two modes (ad-hoc vs infrastructure) and Security (none, wep 40, wep 128, LEAP, Dynamic WEP, WPA&WPA2 Personal, WPA&WPA2 Enterprise). I've tried to mix and match those by trial and error, but that didn't work. How should I proceed? Thank you in advance, Stepan. Sadly those Yet Another Friendly Acronyms don't mean much to me. I tried them all, but wasn't able to connect.

  • have you tried to switch the channel that router is broadcasting, that helped me in 11.04 edition of ubuntu back in the day, you might wanna give it a shot since it's possibly related to the router rather than the computer itself. – biozalp Nov 20 '15 at 22:00
  • Thanks for advice, this solved the problem. I would like to mark it solved but there is a strange restriction (need to wait two days). I will close it later. – Stepan Nov 20 '15 at 23:19
  • i will write it as an answer since it solved your problem and help possible upcoming questions in the future from other users. – biozalp Nov 21 '15 at 13:29

Sometimes routers' broadcasting channels might interfere and cause problems in the wireless systems, (most of the routers come set up as 1st channel) so changing the channel might solve your issue.


Yes, that was the router-computer interface problem. After changing the network to non-broadcasting (sic!) and switching to wpa-psk key with AES only encryption I made it work.

  • Stepan, you shouldn't write your own answer, but accept by clicking the grey at the left of @biozalp's text, which means Yes, this answer is valid! ;-) Then delete this one! – Fabby Nov 23 '15 at 0:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.