1

Still having fun setting up laptop with Ubunut. Everything works great apart from the touchpad. I've had a little play and disabled the touch click, however the pad is very sensitive to touch. I don't mind that so much, it's the fact the touch sensitive pad extends over the right and left buttons.

Does anybody know how to edit the touchpad so I can reduce the area that is registered as touch sensitive?

Or put another way I want to stop the touchpad from extending over the buttons?

I read that you could use Synaptics properties, specifically BottomEdge. But that is not found when I try to run it with the xinput command. Says I need to define it.

Thank you for any assistance.

Here are my settings:

Device 'SynPS/2 Synaptics TouchPad':
        Device Enabled (139):   1
        Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        Device Accel Profile (271):     1
        Device Accel Constant Deceleration (272):       2.500000
        Device Accel Adaptive Deceleration (273):       1.000000
        Device Accel Velocity Scaling (274):    12.500000
        Synaptics Edges (296):  1554, 5390, 1376, 4478
        Synaptics Finger (297): 25, 30, 0
        Synaptics Tap Time (298):       180
        Synaptics Tap Move (299):       252
        Synaptics Tap Durations (300):  180, 180, 100
        Synaptics ClickPad (301):       1
        Synaptics Middle Button Timeout (302):  0
        Synaptics Two-Finger Pressure (303):    282
        Synaptics Two-Finger Width (304):       7
        Synaptics Scrolling Distance (305):     114, 114
        Synaptics Edge Scrolling (306): 0, 0, 0
        Synaptics Two-Finger Scrolling (307):   1, 1
        Synaptics Move Speed (308):     1.000000, 1.750000, 0.034874, 0.000000
        Synaptics Off (309):    2
        Synaptics Locked Drags (310):   0
        Synaptics Locked Drags Timeout (311):   5000
        Synaptics Tap Action (312):     0, 0, 0, 0, 0, 0, 0
        Synaptics Click Action (313):   1, 3, 0
        Synaptics Circular Scrolling (314):     0
        Synaptics Circular Scrolling Distance (315):    0.100000
        Synaptics Circular Scrolling Trigger (316):     0
        Synaptics Circular Pad (317):   0
        Synaptics Palm Detection (318): 0
        Synaptics Palm Dimensions (319):        10, 200
        Synaptics Coasting Speed (320): 20.000000, 50.000000
        Synaptics Pressure Motion (321):        30, 160
        Synaptics Pressure Motion Factor (322): 1.000000, 1.000000
        Synaptics Resolution Detect (323):      1
        Synaptics Grab Event Device (324):      0
        Synaptics Gestures (325):       1
        Synaptics Capabilities (326):   1, 0, 0, 1, 1, 1, 1
        Synaptics Pad Resolution (327): 62, 51
        Synaptics Area (328):   0, 0, 0, 0
        Synaptics Soft Button Areas (329):      3472, 0, 4080, 0, 0, 0, 0, 0
        Synaptics Noise Cancellation (330):     8, 8
        Device Product ID (258):        2, 7
        Device Node (259):      "/dev/input/event4"

I've continued to research the problem and found a information at: https://wiki.archlinux.org/index.php/Touchpad_Synaptics

This had the useful command:

synclient -l | grep BottomEdge
    BottomEdge              = 4478
    AreaBottomEdge          = 0

However setting the values seems to have no effect on my touchpad. Although it does correlate to the values I seen with xinput in the Edges line.

I've tried relatively large values with no effect.

synclient BottomEdge=400000

Any ideas?

1 Answer 1

0

I resolved this problem using the following script in the command line:

xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Finger" 27 30 0 
synclient AreaBottomEdge=4080

The first line seems to slow down the pointer speed and the second pushes the touchpad area up above the left and right buttons.

Worked for me on a Yoga 2 13.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .