I need OpenGL for some programs, but OpenGL is not being used although installed, as is the Nvidia driver. As I understand it, the Asus Eee PC 1215N has an Nvidia ION2 GPU and an Intel graphics unit. On Ubuntu 11.04, the current Nvidia driver is installed, but not used. When I run nvidia-xconfig it creates an xorg.conf file, but X does not start with that.

How do I get OpenGL support running? Is there a way to use the Intel card, or does only the Nvidia support 3D?

If only the Nvidia ION2 supports 3D, how do I get a working xorg.conf for the Nvidia GPU?

UPDATE (2nd January 2012): I have now found that installing Ironhide works for me on the Asus Eee PC 1215n. There are several questions where Ironhide, and its predecessor Bumblebee, are discussed, but most were outdated.

The Linux Hybrid Graphics project has been moving very fast, changing names, features, web addresses and setup. It took me a few hours to figure out what was what. Anyway, the good news is, you can install Ironhide with the Ubuntu Software Center. Ironhide provides a GUI in which you can choose a profile for your device. I had to reboot before everything worked properly. You can also switch between Nvidia and Intel GPU with a console script provided by Ironhide.

Once setup correctly, graphics acceleration works and battery duration increases significantly, e.g. over 5:00 hrs, instead of 3:40 hrs, with Wifi on!

  • possible duplicate of How well do laptops with Nvidia Optimus work?
    – Lekensteyn
    Jan 1 '12 at 11:14
  • @Lekensteyn: You are correct, only that much of the information has since changed, and the question was specific to the Asus Eee PC 1215n. For anyone new to hybrid graphics it's all very confusing. There were three different web sites or more all stemming from the same project. Anyway, now there is a simple solution: The current Ironhide, which has itself changed significantly. It was really confusing with all the outdated and sometimes conflicting information around. Beware of older questions and answers, or you can waste a lot of time.
    – nibl
    Jan 2 '12 at 0:54

This sounds very similar to a problem I just solved on my Asus laptop. It has an integrated Intel graphics card and an Nvidia card in some weird configuration called Optimus where the Intel card runs most of the time because it consumes less power, and then it delegates to the Nvidia card when you run more complex graphics.

Removing the Nvidia driver let the Intel card run properly, and OpenGL now works for me.

During my installation of Ubuntu 11.10, it prompted me to install the Nvidia driver, and I installed it. Most things ran fine, I could watch videos, browse the web, and run drawing or painting programs without problems. However, anything that used OpenGL wouldn't work. I first tried to find out what version of OpenGL I had installed:

sudo apt-get install mesa-utils
glxinfo | grep "OpenGL version"

Glxinfo failed, and I got errors something like this:

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

I tried running sudo nvidia-xconfig and got this warning:

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf. Device section "Default Device" must have a Driver line.

After a bunch of digging, I came across a description of the Optimus configuration. I used lspci to confirm that I did have that configuration:

lspci | grep VGA

It showed that I have two graphics cards:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df6 (rev a1)

I then followed the instructions to remove the nVidia driver.

  1. Reboot into recovery mode. It came up with a second menu that included something like "continue with normal boot." That brought up the desktop in a lower resolution than usual, so I assume it was recovery mode.
  2. I launched System Settings, and then Additional Drivers.
  3. I removed the Nvidia driver.
  4. I rebooted, and OpenGL started working.

Some of this is from memory, but I hope it's close enough to help. It sounds like there are some more advanced ways to use the Optimus configuration with Ubuntu, but I'm happy for now. Also interesting is this answer on Optimus configurations.


Apologies for the confusion, we (the Bumblebee Project team) realized that there was indeed a lot confusion about the proper project to use.

Ironhide is not that current and it's in fact deprecated because it supplies with so-called ACPI calls which haven't been confirmed without knowledge of it. There is the "old MrMEEE/bumblebee-Old-and-abandoned" (ppa:mj-casalogic/bumblebee) and the newest "Bumblebee-Project/Bumblebee" (ppa:bumblebee/stable). For a history, see http://wiki.bumblebee-project.org/History-of-the-project

Ironhide hasn't received major updates since September 2011 and may break your machine (inability to use the graphics card) when uninstalling it if power management is enabled (requiring a reboot). Bumblebee (from the Bumblebee Project team) has several developers using various distributions, resulting in a more stable program with a higher quality level. Installation instructions can be found on Is a NVIDIA GeForce with Optimus Technology supported by Ubuntu?

Bumblebee 3.0 was recently released with better support for Power Management. You can receive the latest release information on https://twitter.com/Team_Bumblebee

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.