I am running on Ubuntu 14.04 x64, and I've just installed FontAwesome - firstly by running install on the ttf file, which I grabbed from http://fortawesome.github.io/Font-Awesome/; and secondly by discovering it's in the repo and running:

sudo apt-get install fonts-font-awesome

Opening the font viewer I can see the fonts:

FontAwesome in Font Viewer

However, when I open the character map, I don't see them:

FontAwesome in Character Map with Latin Script

Should I be selecting any particular Script? I skimmed down the list to see if I can get to see the FontAwesome icons, but nothing jumped out at me.

What I am after is to find the unicode character code for particular icons. I know FontAwesome has a cheat sheet with the unicode's: https://fortawesome.github.io/Font-Awesome/cheatsheet/, however, I'd like to be able to determine the codes from my system.

Another example is font-mfizz, which doesn't offer a similar cheat sheet (at least from what I can tell). I did however find that submitting the woff font - https://raw.githubusercontent.com/DanBrooker/file-icons/master/resources/fonts/font-mfizz.woff - to the site http://www.pkmurphy.com.au/glyphviewer is able to print out the code points:

font-mfizz code points

Is this glyphviewer tool my best option?


You can use Character Map. Select the font and select Character Details

Character Map > Character Details

To find your character, use the view View > By Unicode Block. In All you have a very large list and in this list, you should find your character. But the font has 10FFFF (111411210) characters. Without knowing the code, it's a little bit hard to find your needed character.

You can also filter it out so it only displays the glyphs/icons specific to this font. Go to View > Show only glyphs from this font.

view menu in Character Map

|improve this answer|||||
  • Thanks for the tip on switching to Unicode Block - exactly what I want. – trent Nov 20 '15 at 10:16
  • You mean the penguin? – A.B. Nov 20 '15 at 10:17
  • 1
    I have three different Awesome fonts in my system, perhaps that's the reason. – A.B. Nov 20 '15 at 10:18
  • Sorry... I noticed your screenshot is slightly different to the one I see, hence the different code. – trent Nov 20 '15 at 10:18
  • 1
    @trent thanks for the edit, It's a great improvement. :) – A.B. Nov 20 '15 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.