14

After a fresh install on a brand new HP Probook 470 G3 everything is working perfect only sound :-( Try to re-install all alsa parts, but still no sound.

If the manual is correct it is a Conexant CX7501

Alsamixer is showing only spdif (3x) all on 0. I cannot select any other sound cards. It seems like I missing the (intel) drivers ?

alsa-info seems oke.. what do I miss ?

See also: http://www.alsa-project.org/db/?f=fd172ad3823bcaec1a8e2b6af031b394b986a466

This could be the problem:

dmesg | grep snd

[   12.349541] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[   12.349681] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   15.383652] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to polling mode: last cmd=0x000f0000
[   16.395482] snd_hda_intel 0000:00:1f.3: No response from codec, disabling MSI: last cmd=0x000f0000
[   17.399551] snd_hda_intel 0000:00:1f.3: Codec #0 probe error; disabling it...

I have added acpi=off to grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=off
update-grub

Installed pavucontrol

removed alsa-base.conf and reboot

added

options snd-hda-intel enable_msi=1

to /etc/modprobe.d/alsa-base.conf

Some extra info:

uname -a
Linux ProBook 4.2.0-18-generic #22-Ubuntu SMP Fri Nov 6 18:25:50 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

lspci -v | grep -A7 -i "audio"
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
Subsystem: Hewlett-Packard Company Device 8102
Flags: bus master, fast devsel, latency 64, IRQ 16
Memory at c2420000 (64-bit, non-prefetchable) [size=16K]
Memory at c2410000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [50] Power Management version 3
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Kernel driver in use: snd_hda_intel

lsmod | grep snd
snd_hda_intel          36864  0
snd_hda_codec         135168  1 snd_hda_intel
snd_hda_core           65536  2 snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               102400  3 snd_hda_codec,snd_hda_intel,snd_hda_core
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  8      snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              16384  1 snd

Still no sound :-(

  • did you try to use kernel 4.3.3 some say it has fixes for skylake intel processors for sound (not helped for me, but add one more sound output) – leanid.chaika Dec 17 '15 at 19:49
  • 1
    I have exactly the same problem with HP 440 G3. I have tried 4.3 and 4.4 kernel with no luck. If you found any solution please share it back here. – Kon Pal Jan 9 '16 at 15:23
15

I found the solution (!), create a new file /etc/modprobe.d/intel.conf

add the following options:

options snd-hda-intel single_cmd=1
options snd-hda-intel probe_mask=1

reboot....

| improve this answer | |
  • Works for me too (linux mint 17.3) thanks a lot ! – Ilan Frumer Jan 11 '16 at 21:56
  • 1
    Works for me too ubuntu 15.10 – santer Jan 12 '16 at 11:22
  • Great! Works for me on Debian 4.4 and Asus B150M-C – zoechi Feb 20 '16 at 16:58
  • Then please mark this as the solution/best answer – Peter Nerlich Mar 6 '16 at 17:56
  • I did this and it worked, but the next time I was booting my pc my headphones started screeching and I thought they were going to explode – mickadoo Mar 9 '16 at 10:29
1

The solution works for Ubuntu 14.10 also! I have HP ProBook 470 G3, too.

Being new to linux, it took me some time to use the hint. This is the full set of commands; the first one creates, the second one edits the file.

sudo touch /etc/modprobe.d/intel.conf
sudo nano /etc/modprobe.d/intel.conf

Type the two options below in the editor, press ctrl+x to exit, type y to confirm and enter to confirm filename.

options snd-hda-intel single_cmd=1
options snd-hda-intel probe_mask=1

Then reboot.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.