0

I just installed Kubuntu (latest version) on dual boot with Windows 8.1 on my ASUS laptop. My boot manager is rEFInd.

I installed Kubuntu without grub (using ubiquity -b) and it installed and worked fine.

Kubuntu prompted me to install the latest drivers for my Nvidia GTX860M (my laptop also has Intel Integrated Graphics). I installed them, rebooted, and now I am stuck on the boot screen, prompting "Wait for Plymouth screen to quit". I cannot access the desktop nor the terminal (using alt+F2).

1 time out of 10, I manage to access the home screen on KDE. When I log in into my session, the screen just freezes (mouse/keyboard not responding).

I googled the issue, but all the solutions rely on using the terminal and editing the grub config file (but I am not using grub).

Would a workaround be possible using my live USB distribution ? Also, how can I make sure Kubuntu installs the proper drivers for my GTX ?

Note that the install is fresh, so I really don't mind erasing it if I have to, even though it would be better not to.

Thank you very much for your help.

5
  • I'm a little confused about how how managed to install Kubuntu without grub - did you find a guide to that somewhere? Nov 19, 2015 at 15:03
  • Hi! I simply used the live USB insinstall, launched with the command "ubiquity -b", which apparently skips installing grub. I simply googled " install Kubuntu without grub".
    – vxid
    Nov 19, 2015 at 15:10
  • OK - If you can prompt rEFInd into booting Ubuntu into a recovery mode, then you could remove the nvidia drivers entirely. I'd try ctrl-alt-f1 to see if you can get a tty instead of alt-f2, but in either case your going to need t do some terminal work. This question delineates the required commands. Nov 19, 2015 at 15:25
  • Thanks for your answer. I'll try this solution as soon as I get a working Internet connection for my computer and I'll report back to you.
    – vxid
    Nov 19, 2015 at 15:32
  • Hi again. I tried applying the guide, nonetheless, nothing worked as expected. Apparently, no Nvidia packages are installed on my os. Moreover, no xorg config files are to be found. I maybe found a tutorial for doing the opposite (I.e. uninstalling nouveau and enabling up to date Nvidia drivers) : allaboutlinux.eu/… but I can't get internet to work in the recovery mode (wired Ethernet). Thanks for your help, and sorry for the formatting, I am on mobile right now.
    – vxid
    Nov 19, 2015 at 16:28

2 Answers 2

0

I managed to find a solution.

I had to uninstall the nouveau drivers through recovery boot and install the proper nvidia drivers, the whole procedure is explained very well on this page : http://www.allaboutlinux.eu/remove-nouveau-and-install-nvidia-driver-in-ubuntu-15-04/ (You can skip the second page).

The only twist I had to use was to obtain the drivers (since I had no access to the desktop) using the command "sudo apt-get install nvidia-XXX", XXX being your driver's version (you can find the info on the Nvidia website).

Note that this command line may or may not work out of the box (I went through a lot of trial and error to make it work).My guess is that it would also be possible to download the drivers elsewhere and mount them through the recovery, and then to follow the instructions in the guide.

Everything worked fine afterwards.

2
  • you should add how exactly you did it, step by step. short answer dont help new users Nov 19, 2015 at 20:08
  • Thanks for the feedback, I am still new to this but sure. My answer has been edited.
    – vxid
    Nov 19, 2015 at 21:56
0

This is my proposed solution to most Nvidia related problems. Being unable to access tty could mean that GRUB wasn't able to load video drivers due to nouveau screwing things up. With rEFInd, you should be able to press tab to edit boot options and add nouveau.modeset=0 to boot, then follow the instructions linked prior for a permanent solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.