1

Windows does not recognize my USB drive. Windows Explorer, Diskpart and other tools have been tried by me. The port is working. Only the device manager detects the drive (And shows a yellow triangle next to it). The drive name is Intenso Ultra Line. Other information such as ID's of the USB drive are in the outputs below.

On Linux, GParted and other tools also do not detect the drive. But the kernel does recognize the drive:

lsusb -t: USB Drive gets detected. (Port 2):

/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M

|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M

   |__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M

lsusb -v: USB Drive gets detected:

http://pastebin.com/CUME3g8P

lsusb: USB Drive gets detected:

Bus 002 Device 007: ID 1f75:0917 Innostor Technology Corporation

lsblk: USB Drive does not get detected.

  • Output not needed -

Here is my Kernel-Log:

http://pastebin.com/ppmVSpGB

Help is very appreciated!

0

Have you tried installing Smartmontools?

It's able to detect some devices by vendor/manufacturer 1f75 (Innostor Technology Corporation). According with your logs, 1f75 is the manufacturer of your device, hence I would give Smartmontools a try.

[edit]: since no GUI application has so far detected your USB device, I am in the hope that by installing and running Smartmontools your device will be detected by it and become visible inside Smartmontools' window, hence making it able for you to identify it's special device file (/dev/something) or at least its serial number (which is part of its unique id).

In order to install Smartmontools' precompiled package in Ubuntu, just run:

sudo apt-get install gsmartcontrol

...and then run it as root:

sudo gsmartcontrol-root

After this, plug in your Intenso Ultra Line drive at any USB port and then at the Smartmontools application window hit Ctrl R in order to rescan the SMART-capable devices. If your USB drive shows up (as expected), you'll see which special device file should be used in order to try to mount it by hand. E.g. if Smartmontools shows your device at /dev/sdb, then you should be able to mount its first partition (/dev/sdb1) by running a command like this (at the example below I'm assuming that your USB drive's first partition filesystem is VFAT):

sudo mkdir /mnt/intenso && sudo mount /dev/sdb1 /mnt/intenso -w -t vfat -o nodev,nosuid,uid=1000,gid=1000,flush,shortname=mixed,utf8=1,dmask=0077,showexec

If Smartmontools (gsmartcontrol-root) doesn't show your device's special device file but shows its serial number (e.g. 14122400007141, according to your "Broken USB drive" kernel log), then you can use the command below in order to look for the device's full id code:

ls -las /dev/disk/by-id | grep -i 14122400007141

...which shall return something like this:

usb-Intenso_Ultra_Line_14122400007141-0

usb-Intenso_Ultra_Line_14122400007141-0:0-part1

...so then you'll be able to mount its first partition by running a command like this:

sudo mkdir /mnt/intenso && sudo mount /dev/disk/by-id/usb-Intenso_Ultra_Line_14122400007141-0\:0-part1 /mnt/intenso -w -t vfat -o nodev,nosuid,uid=1000,gid=1000,flush,shortname=mixed,utf8=1,dmask=0077,showexec

If your drive isn't visible not even inside the Smartmontools (gsmartcontrol-root) application window, you can create a udev rule for your device by adding the following to a file in /etc/udev/rules.d/, such as (e.g.) 8-intenso-ultra-line.rules. Assuming that you have Gedit installed (if not: sudo apt-get install gedit), run this:

sudo gedit /etc/udev/rules.d/8-intenso-ultra-line.rules

...and then add this to the file:

# Intenso Ultra Line USB drive by Innostor Technology Corp.
KERNEL=="sd*", ATTRS{serial}=="14122400007141", ATTRS{idVendor}=="1f75", ATTRS{idProduct}=="0917" SYMLINK+="intenso%n"

(the serial, idVendor and idProduct attributes can be confirmed by running the command sudo lsusb -v | grep -A 5 1f75)

Now save the file /etc/udev/rules.d/8-intenso-ultra-line.rules, exit Gedit and then run the command below so udev updates this info and restarts its daemon:

sudo udevadm trigger && sudo service udev restart

After this, you can see if your device's symlinks (e.g. intenso1, for its first partition) are listed in /dev:

ls /dev

If no changes happened, restart your system (sudo telinit 6) and then try mounting the USB drive:

sudo mkdir /mnt/intenso1 && sudo mount /dev/intenso1 /mnt/intenso1 -w -t vfat -o nosuid,uid=1000,gid=1000,flush,shortname=mixed,utf8=1,dmask=0077,showexec

If it works, you can add it to /etc/fstab so you don't have to always run it by hand. Just:

sudo gedit /etc/fstab

...then append something like this:

# Intenso Ultra Line USB drive by Innostor Technology Corp. (first partition):
/dev/intenso1 /media/intenso1 vfat rw,nosuid,uid=1000,gid=1000,flush,shortname=mixed,utf8=1,dmask=0077,showexec 0 0
  • I have now installed it. But I cannot find any tutorials related to recovery or detection. All I can find is some SMART-Monitoring... Could you provide some commands? – user464939 Nov 20 '15 at 17:11
  • I edited my answer in order to try to make it more useful. Smartmontools was supposed to help you identify your drive's special device file (e.g. /dev/sdb) so you could later mount it by hand. In the worst case scenario, I expect that you can use Smartmontools to confirm your device's serial number and then combine it with your previous lsusb output data in order to (i) create a udev rule for setting up a static symlink mountpoint to your USB drive and (ii) use mount to mount your drive using such static symlink. – Yuri Sucupira Nov 21 '15 at 4:53
  • Mint and Ubuntu were not able to open the application. Now I tried Debian (Live Boot) and the application opened. But I cannot see my drive - now I'll try this on installed Debian 8.2.0. But still thanks! – user464939 Nov 21 '15 at 11:16
  • Nope. Still nothing detected :( – user464939 Nov 21 '15 at 11:42
  • You mean only Smartmontools didn't work? Or not even creating an udev rule worked? Does ls -las /dev/disk/by-id return anything? Because your system kernel detected your device, inside /dev/disk/by-id there should be something like usb-Intenso_Ultra_Line_14122400007141-0 (conventionally, the file name starts with usb, has the device's name and serial number, and ends with zero). If at least there's a file for your device inside of /dev/disk/by-id, try completely wiping its data with sudo dd if=/dev/zero of=/dev/disk/by-id/usb-Intenso_Ultra_Line_14122400007141-0 bs=1M – Yuri Sucupira Nov 21 '15 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy