I'm having trouble booting kubuntu after installing fglrx-updates (or just fglrx). I originally was having issue described in https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1493888 however the fix for this has recently been released. Even with the update I still can't boot Kubuntu, but I can get a bit further now (it used to only show "Starting version 219", but Kubuntu still gets stuck while booting and showing "Kubuntu" logo). I do want to use fxglr (for better performance in games and because I'm having random issues with open source driver which although not game breaking are annoying). Is there any way to diagnose and fix that?

lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2

00:02.0 Display controller [0380]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0162] (rev 09)
    Subsystem: ASRock Incorporation Motherboard [1849:0162]
    Kernel driver in use: i915
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT [Radeon R7 370 / R9 270X/370 OEM] [1002:6810]
    Subsystem: PC Partner Limited / Sapphire Technology Device [174b:e271]
    Kernel driver in use: radeon

dpkg-query -l fglrx*

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                   Version           Architecture Description
un  fglrx-amdcccle         <none>            <none>       (no description available)
ii  fglrx-amdcccle-updates 2:15.201-0ubuntu1 amd64        Catalyst Control Center for the AMD graphics accelerators
un  fglrx-control          <none>            <none>       (no description available)
un  fglrx-control-qt2      <none>            <none>       (no description available)
un  fglrx-driver           <none>            <none>       (no description available)
un  fglrx-driver-core      <none>            <none>       (no description available)
un  fglrx-glx              <none>            <none>       (no description available)
ii  fglrx-updates          2:15.201-0ubuntu1 amd64        Video driver for the AMD graphics accelerators
ii  fglrx-updates-core     2:15.201-0ubuntu1 amd64        Minimal video driver for the AMD graphics accelerators


log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
grep dmesg status 256
dmesg status 256 == 0? No
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is fglrx loaded? yes
Was fglrx unloaded? no
Is fglrx blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? yes
Is nouveau loaded? no
Is nouveau blacklisted? no
Is fglrx kernel module available? yes
Is nvidia kernel module available? no
Vendor/Device Id: 8086:162
BusID "PCI:0@0:2:0"
Is boot vga? no
Vendor/Device Id: 1002:6810
BusID "PCI:1@0:0:0"
Is boot vga? yes
Error: can't access /sys/bus/pci/devices/0000:01:00.0/driver
The device is not bound to any driver. Skipping...
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card0", driven by "i915"
Found "/dev/dri/card0", driven by "i915"
Number of connected outputs for /dev/dri/card0: 0
Does it require offloading? no
last cards number = 1
Has amd? no
Has intel? yes
Has nvidia? no
How many cards? 1
Has the system changed? No
main_arch_path x86_64-linux-gnu, other_arch_path i386-linux-gnu
Current alternative: /usr/lib/fglrx/ld.so.conf
Current core alternative: /usr/lib/fglrx-core/ld.so.conf
Is nvidia enabled? no
Is fglrx enabled? yes
Is mesa enabled? no
Is pxpress enabled? no
Is prime enabled? no
Is nvidia available? no
Is fglrx available? yes
Is fglrx-core available? yes
Is mesa available? yes
Is pxpress available? yes
Is prime available? no
Single card detected
No change - nothing to do
  • pls provide information on graphicscard equipment: lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2 Nov 19, 2015 at 21:24
  • Added lspci info Nov 20, 2015 at 13:20

1 Answer 1


If its stuck like this and u cannot diagnose (which is a pitty) u can still use the recovery-option of the most recent kernel in the GRUB-menu to come to a root-shell. But before that u will have to establish a "network-connection" from within the recovery-menu

Then run there sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade

exit would return you to the recovery-menu (just said) – would recomend sudo reboot then - If I understood yr Q right and you are seeking a way to catch the update. If not so then

Option 2: Another opportunity would be to edit the 1st start-sequence in the GRUB-menu and append the boot-option nomodeset If this alone doesn't help insert xforcevesa in addition. Just place these options between "quiet plymouth" Hope this helps ;-)

edit3: Something went obviously wrong, in order to find out the right proceeding on installation of proprietary software, you firstly have to revert your system back into a stable state - remove fglrx wt all its components.

Reinstall the missing parts for the opensource driver.

For error analysis it is essential to share information about your systems components in question. Not having this can end up in a time-consuming guess & try + lead to frustration on both sides. It also reduces the risk to get any breakage or malformation.

This answer already given may help you to understand the complexity+necessary steps – https://askubuntu.com/a/74172/472414 (is-my-ati-graphics-card-supported-in-ubuntu)

  • Sorry I clarified the question: I do want to use fglrx. I can boot into Kubuntu if I go to recovery mode and apt-get purge fglrx*. I tried adding nomodeset and xforcevesa to grub options with fglrx-updates installed (although there was no "quiet plymouth", but I saw "quiet splash" and added it there), however it didn't change anything. Nov 19, 2015 at 20:26
  • Once u experienced now u can start thru with the recovery-mode u can now start analyzing: $/var/log/gpu-manager.log $dpkg-query -l fglrx* Nov 19, 2015 at 21:20
  • 1
    Sorry I'm not trying to hide information, I just don't know what information is needed. If you need anything else just let me know. In the meantime I looked over gpu-manager.log and I noticed an error there. Seems it can't find driver. I tried googling the problem, though it seems there's only one relevant link and even that talks about hybrid graphics which I'm pretty sure I don't have since this is desktop PC and 3650 radeon which is a lot older model and makes sense it's not supported. I've also checked the link you provided, didn't help much and compatibility list seems outdated. Nov 20, 2015 at 13:51
  • Thanks for providing the relevant information. From the above given link (is my ati-graphics-card supported in Ubuntu) -> [wiki.cchtml.com/index.php/… Sorry to say so, AMD stopped supporting older graphics cards with FGLRX a while ago. U need to rely in the OpenSource Driver RADEON. Nov 20, 2015 at 14:04
  • 1
    I'm familiar with command line, just not with linux structure in general. I'm willing to try out proposed packages, if there's better way to do this through command line I don't mind doing it that way Nov 20, 2015 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.