I am using Ubuntu 14.04.3 LTS, I was using MySQL 5.6.24 via (https://launchpad.net/~ondrej/+archive/ubuntu/mysql-5.6) and have just tried to update it but it dies with:

0 [Note] /usr/sbin/mysqld (mysqld 5.6.27-0ubuntu0.14.04.1) starting as process 3486 ...
3486 [Note] Plugin 'FEDERATED' is disabled.
3486 [Note] InnoDB: Using atomics to ref count buffer pool pages
3486 [Note] InnoDB: The InnoDB memory heap is disabled
3486 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
3486 [Note] InnoDB: Memory barrier is not used
3486 [Note] InnoDB: Compressed tables use zlib 1.2.8
3486 [Note] InnoDB: Using Linux native AIO
3486 [Note] InnoDB: Using CPU crc32 instructions
3486 [Note] InnoDB: Initializing buffer pool, size = 128.0M
3486 [Note] InnoDB: Completed initialization of buffer pool
3486 [Note] InnoDB: Highest supported file format is Barracuda.
3486 [Note] InnoDB: 128 rollback segment(s) are active.
3486 [Note] InnoDB: Waiting for purge to start
3486 [Note] InnoDB: 5.6.27 started; log sequence number 1059121176
3486 [Note] Binlog end
3486 [Note] InnoDB: FTS optimize thread exiting.
3486 [Note] InnoDB: Starting shutdown...
3486 [Note] InnoDB: Shutdown completed; log sequence number 1059121186
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.6 (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have run through the following answers:

E: Mysql-server-5.5 Installation Error

mysql-server-5.5 has unmet dependencies

Why did installation of MySQL 5.6 on Ubuntu 14.04 fail?

How do I resolve unmet dependencies after adding a PPA?

But I am still no closer to figuring out what is wrong with this other than that it might be something to be with dependencies. I have tried:

dpkg -l | grep mysql

ii  libdbd-mysql-perl                   4.025-1                              amd64        Perl5 database interface to the MySQL database
ii  libmysqlclient18:amd64              5.6.25-3+deb.sury.org~trusty+1       amd64        MySQL database client library
ii  mysql-client-5.6                    5.6.27-0ubuntu0.14.04.1              amd64        MySQL database client binaries
ii  mysql-client-core-5.6               5.6.27-0ubuntu0.14.04.1              amd64        MySQL database core client binaries
ii  mysql-common                        5.6.25-3+deb.sury.org~trusty+1       all          MySQL database common files, e.g. /etc/mysql/my.cnf
iF  mysql-server-5.6                    5.6.27-0ubuntu0.14.04.1              amd64        MySQL database server binaries and system database setup
ii  mysql-server-core-5.6               5.6.27-0ubuntu0.14.04.1              amd64        MySQL database server binaries
rc  php5-mysqlnd                        5.5.30+dfsg-1+deb.sury.org~trusty+1  amd64        MySQL module for php5 (Native Driver)

Which indicates that mysql-common is a lesser version than the rest of them, not sure if this makes much of a difference here though as on another system it is there but at a higher revision than the rest of them at .24.

Found this that suggests that it may be something to do with the apparmor (had no idea that this could affect things) config but I did not upgrade from 5.5:


Only other option I can see here for me is to try to update to 5.7 and see if that has any change for my problem.

Any additional feedback or suggestions on how I could resolve this would be greatly appreciated as I really have no idea why this is happening now.


1 Answer 1


The problem that was had here is that the PPA giving mysql 5.6 support to Ubuntu lists a newer package available on the Ubuntu repos. I guess switching between the version supported by the PPA and that of the official Ubuntu realease caused a problem.

Removing all packages shown with dpkg -l | grep mysql and reinstalling worked out. Don't forget to save the list of installed packages if you have any over and above the standard ones ;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .