1

Since I am on Ubuntu, I'll try to have X11 forwarding through ssh on a remote desktop. But unfortunately it does not work. Before I do this :

ssh -X username@hostname

and then for example :

gedit

But now under Ubuntu 15.10 It does not work and I have this message :

$ gedit Failed to connect to **Mir**: Failed to connect to server socket: No files or folders of this type Unable to init server: Unable to connect: Connection refused

(gedit:2492): Gtk-WARNING **: cannot open display:

So my question is how to have X11 forwarding through ssh ?

1 Answer 1

-1

You need to enable X-Forwarding in the SSH server configuration, in /etc/ssh/sshd_config

It should look like:

X11Forwarding Yes

Uncomment any comments before this line.

After restarting the SSH Server everything should works fine.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.