1

After my laptop with AMD HD4570 discrete GPU (which entered legacy branch and no more AMD proprietary support for Linux) died I tried to give AMD another shot and bought a new laptop with switchable graphics and not just any graphics...AMD/AMD switchable graphics, but came close to hitting myself in the head when I installed the proprietary driver, and you probably guessed it.....there is no driver for my discrete graphics card for Linux even though it was released this year, more exactly in June. The AMD CCC detects only the integrated graphic processor.

I tried BIOS but there is no option to switch/disable GPUs, also tried the switcheroo https://help.ubuntu.com/community/HybridGraphics but it doesn't work, even though sudo grep -i switcheroo /boot/config-* shows "Y", after I changed grub file to how the help page discribes, sudo ls -l /sys/kernel/debug/vgaswitcheroo/switch outputs "file not exist" even after I try using sudo su and manually navigating to /sys/kernel/debug....vgaswitcheroo directory was missing.

I have a Dell Inspiron 15 5555 with AMD A8-7410 (with integrated R5 graphic processor) and AMD R5 M335 discrete graphic card.

Using lspci -v | grep VGA gives the following output:

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon APU A4-6000 with R2 Graphics] (rev 45) (prog-if 00 [VGA controller])

And lspci -v | grep Display gives the following output:

01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M] (rev ff) (prog-if ff)

It's funny though how AMD R5 M2xx have drivers and M3xx do not. Is there a way to use my discrete GPU? Using Ubuntu 14.04 X86_64

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.