9

I am running Ubuntu GNOME 15.10 with GNOME 3.18 and would like to know if there is some way to get CTRL + ALT + T to open a new Terminal window even if one is already open (that is rather than just bring the currently open one to the front)?

  • In my installation CTRL+ALT+T always opens a new terminal regardless (GNOME 3.16.4). – kos Nov 18 '15 at 13:12
  • In every gnome install I've just added "gnome-terminal" as a custom shortcut, and it's worked exactly as I expected it to, it opens a new terminal window. Is there some functionality you want that I'm missing? – Mischka Nov 18 '15 at 15:05
  • @Mischka: No, I think that for some reason it doesn't work quite right on my version... But the current accepted answer seems to fix that. – user364819 Nov 18 '15 at 16:41
9

The funny thing is that on Unity, CTRL + ALT + T does open a new window, apparantly not on Gnome...

To make the setup:

  1. First disable the existing command/key combination with the command:

    gsettings set org.gnome.settings-daemon.plugins.media-keys terminal ""
    

    Which will make CTRL + ALT + T "available" again for another command.

  2. Now open keyboard settings: System Settings > "Keyboard" > "Shortcuts" > "Custom Shortcuts". Click the "+" and add the command:

    gnome-terminal --window-with-profile=<profilename>
    

    to CTRL + ALT + T, where <profilename> is the name of your profile, most likely Default

From man gnome-terminal:

   --window-with-profile=PROFILENAME
             Open  a new window containing a tab with the given profile.
             More than one of these options can be provided.
  • 1
    The answer is good, but also with '<Primary><Alt>t' for gsettings get org.gnome.settings-daemon.plugins.media-keys terminal GNOME opens a new terminal per default. – A.B. Nov 18 '15 at 12:13
  • @A.B. Good to know, apparently on OP's system it didn't for some reason... – Jacob Vlijm Nov 18 '15 at 12:15
  • 1
    Yes, that's strange. – A.B. Nov 18 '15 at 12:15
  • 1
    @A.B. Indeed. I'm on GNOME and Ctrl+Alt+T opens a new terminal no matter if I have one opened already. – kos Nov 18 '15 at 12:20
6

It's pretty easy to make Ctrl+Alt+T alive in gnome:

  1. Search for Keyboard shortcuts in Gnome home menu

  2. Add a custom shortcut in Keyboard

  3. Add (+)

    • Name: gnome-terminal
    • Command: gnome-terminal
    • Ctrl+Alt+T

Adding custom commands

  • 1
    easy and quick. Can be easily changed later. Good one. – devprashant Aug 18 '18 at 2:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy