4

I'm now using Ubuntu 14.04.3 and using Unity tool for change some effects. Curiously, I changed Window spread to "on" in the Window spread tag, the system automatically logged out. When I tried to login, I entered the main screens but immediately the system logged out again. After efforts login few times, the situation still happened.

However, I login successfully with a Guest account. I tried some solutions on the Internet but there is no point to solve my problem. What should I do?

2
+25
  1. Press CtrlAltF1 to switch to console (tty1)
  2. Login
  3. Check the running dbus-deamon

    ps aux | grep dbus-deamon
    
  4. Set X display & dbus address variables

    export DISPLAY=:0
    export DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bN5xD2OA1Y
    

    /tmp/dbus-bN5xD2OA1Y set as example, copy your own from previous step.

  5. Run this to get the enabled Compiz plug-ins

    dconf read /org/compiz/profiles/unity/plugins/core/active-plugins
    

    Output should be something like:

    ['core', 'composite', 'opengl', 'compiztoolbox', 'grid', 'wall', 'vpswitch', 'snap', 'mousepoll', 'copytex', 'commands', 'place', 'move', 'regex', 'resize', 'imgpng', 'unitymtgrabhandles', 'session', 'animation', 'fade', 'expo', 'workarounds', 'ezoom', 'unityshell', 'scale']
    
  6. Then this after you remove scale plug-in the for window spread, example:

    dconf write /org/compiz/profiles/unity/plugins/core/active-plugins "['core', 'composite', 'opengl', 'compiztoolbox', 'grid', 'wall', 'vpswitch', 'snap', 'mousepoll', 'copytex', 'commands', 'place', 'move', 'regex', 'resize', 'imgpng', 'unitymtgrabhandles', 'session', 'animation', 'fade', 'expo', 'workarounds', 'ezoom', 'unityshell']"
    

    However, I noticed from your output in chat that you have gnome compatibility plugin enabled 'gnomecompat', which is not compatible with unity plugin. (from a previous experience, it make unity crash)

  7. Press CtrlAltF7 to switch to back to GUI console (tty7)

Note: As retyping such long command in terminal is error prune, I wrote a script to do same instructions

wget -O au_699540.sh http://pastebin.com/raw.php?i=swuzDuJ3
chmod +x au_699540.sh
./au_699540.sh

I don't want to make it long for you. There is another quick trick but it has a drawback. It will reset all your user settings stored in dconf database (This includes Unity, Gnome & Some GTK apps)

sudo rm ~/.config/dconf/user
|improve this answer|||||
  • This is not working. It came up with this error - error: Cannot autolaunch D-Bus without X11 $DISPLAY Usage: dconf write KEY VALUE Write a new value to a key Arguments: KEY A key path (starting, but not ending with '/') VALUE The value to write (in GVariant format) – Priyansh Nov 28 '15 at 7:04
  • No I already tried that, but it was of no use. – Priyansh Nov 28 '15 at 7:54
  • 1
    Yes I have lightdm – Priyansh Nov 28 '15 at 8:05
  • Yes, no issue with that. – Priyansh Nov 28 '15 at 13:10
  • Let us continue this discussion in chat. – user.dz Nov 28 '15 at 13:17
0

maybe this can help you to login, after this you can reset compiz to default with this command:

dconf reset -f /org/compiz/
|improve this answer|||||
  • Sorry coming up with error message. – Priyansh Nov 28 '15 at 7:09
0

Reset Unity, wiping all changes to configuration.

  1. Swtich to a tty console (CtrlAltF1)
  2. Login
  3. unity-tweak-tool --reset-unity
  4. sudo reboot
|improve this answer|||||
  • Sorry, this is not helping. – Priyansh Dec 4 '15 at 4:03
0

Have you tried the tty, and enter this in th tty:

sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install dkms
sudo dkms-reconfigure unity
sudo apt-get install -f

and it might work fine this way.

|improve this answer|||||
  • Sorry but even this is not working – Priyansh Dec 2 '15 at 2:42
  • Have you tried this sudo apt-get install --reinstall unity, and then this unity --replace-reset-icon & disown, and it might work fine this way. – Michael Dec 2 '15 at 16:33
  • There is no problem with unity. They all suggested this me to do before. – Priyansh Dec 4 '15 at 4:04
0

I've read this thread: Unity crash in Ubuntu 14.04

After all, I resolved this problem by typing

mv ~/.config/dconf/user ~/.config/dconf/user.old

I followed this tips, they changed back to the default Ubuntu settings. Although it isn't the best solution, it worked fine for me. Thanks everyone taking time to help me solve this problem.

|improve this answer|||||
0

Press ctrl + Alt + F1, to bring up a tty. The type username and password. Then:

Install dconf-tools: sudo apt-get install dconf-tools

Reset Compiz and Unity: dconf reset -f /org/compiz/

Reset Unity: setsid unity

If that also fails, then maybe deleting the settings files might help:

rm  -rf ~/.compiz-1 
rm -rf ~/.config/compiz-1

Lastly, you could try the following:

sudo apt-get install dconf-tools
dconf reset -f /org/compiz/
unity --reset-icons
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.