2

I just completed an upgrade to Ocelot from Natty. I can't tolerate the Unity interface, so I'm attempting to run the classic shell.

I followed the instructions on this thread. However running the gnome-tweak-tool and disabling the "filemanager handles desktop" option yields only a blank screen. I still have no panels, only now I see neither the Nautilus menubar nor the desktop icons.

After selecting GNOME classic session and logging in, I see no panels whatsoever. Nautilus has loaded a file-menu bar where my top panel should instead be. Right-clicking (or alt+right click) on this menu has no response, so I'm unable to add new panels.

I've tried various things, such as purging and reinstalling gnome packages. I've deleted user setting folders such as: ~/.gconf ~/.gnome ~/.gnome2 ~/.metacity These have had no effect.

Any suggestions?

  • 1
    If you create a new user, do you have the same issue? What graphics card do you have and do you use any graphics drivers? – fossfreedom Oct 20 '11 at 21:50
  • 1
    Next time you can just edit your question and we can reopen it – Jorge Castro Oct 20 '11 at 21:50
  • @fossfreedom Good idea. Just made a new user account and I see the same problem. This must mean it is unrelated to anything in my user folder. Graphics cards are a Radeon HD 5850 and a 5830. Using ATI Catalyst drivers I had installed prior to upgrade to Ocelot. Do you think that avenue is worth further exploration? – Major Murphy Oct 20 '11 at 22:18
  • 1
    You should deactivate (if there aren't already) in the additional hardware drivers window and then reinstall the graphics driver. If this doesnt work - try removing one of the cards and seeing if you still have the same issue - it could be a real bug with users with two similar graphics cards installed. – fossfreedom Oct 20 '11 at 22:22
  • I personally got used to Ubuntu 10.04 10.10 and 11.04; I love the flexibility and total control of their windows manager. The first bad experience was upgrading from 10.10 to 11.04 when I first noticed Unity with the option to switch to classic; all my 3D graphics were gone, hidden or not operational. I really love Linux Ubuntu and decided to give it a second chance; I installed a new fresh copy of 11.10. It went well. At the Login dialog box there are only two options, { Ubuntu (3D) } and Ubuntu 2D. There is very little information out there as what we can use as a Window Manager for 11.10. * – Carlos Tolossa Oct 20 '11 at 23:25
3

I discovered gnome-panel was crashing:

(gnome-panel:9694): Gtk-CRITICAL **: gtk_style_context_get: assertion `priv->widget_path != NULL' failed

It looks like a similar issue here.

As @fossfreedom suggested, it is probably related to video drivers. As a workaround, I followed instructions here for uninstalling fglrx and reinstalling the open-source driver.

0

You can't use anymore Ubuntu Classic. Now you can use Ubuntu with Unity 3D or 2D, or you can install gnome-shell. You can also use the fallback mode of gnome-shell that looks similar to Ubuntu Classic but it's not it.

For install gnome shell do this:

  1. Open a terminal by hitting CTRL + ALT + T
  2. Insert and run this command:

    sudo apt-get install gnome-shell
    

For install gnome-fallback-mode do this:

  1. Open a terminal by hitting CTRL + ALT + T
  2. Insert and run this command:

    sudo apt-get install gnome-session-fallback
    

Then log out and select GNOME Classic for the gnome fallback session or GNOME Shell for gnome shell at the LightDM login screen.

  • Please try not to create the impression that there are only four shells to choose from in Ubuntu. There are many. Most people who want the old experience, should try Xfce, which is quite nice. (Much better, imho, than Gnome Panel ever was) – Jo-Erlend Schinstad Oct 20 '11 at 21:53
  • @eNry I already have packages installed including: gnome-shell, gnome-panels, gnome-session-fallback. Login session options include: GNOME, GNOME Classic, and GNOME Classic (no effects). All three session options result in no panels. Thank you though. – Major Murphy Oct 20 '11 at 22:06
  • @Jo-ErlendSchinstad Good point, Xfce may be the simplest solution at this point. Thanks. – Major Murphy Oct 20 '11 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.