With Ubuntu 14.04 LTS I had no problem connecting to the different networks of my university, for example eduroam and others that use the same configuration. The configuration is the following:

  • SSID: eduroam
  • Security : WPA & WPA2 Enterprise
  • Authentication : Protected EAP (PEAP)
  • CA certificate: Thawte_Premium_Server_CA.pem (in /etc/ssl/certs)
  • PEAP version : Automatic
  • Inner authentication : MSCHAPv2
  • Username and password provided by the university.

Now with Ubuntu 15.10, the network keeps asking for me to confirm the password (already written in the dialog, just have to press enter) password and never connects. I have tried some of the answers to similar questions:

  • got the same issue on ubuntu 15.10 with correct username and password (works on windows dualboot and android smartphone). On the same ubuntu install it worked 10months ago. Reading some other reports i suspect its an issue with the new versions of Network-manager-vpnc or wpa-supplicant or such. – k1l Dec 16 '15 at 16:11
  • I have recently moved my linux installations to Arch, and had the same problem. I solved it by installing an older version of the wpa_supplicant. I suppose that you would need to do the same in Ubuntu. Also, try filling both the "User" field and the "Anonymous identity" field with your username. – kauron Jan 29 '16 at 13:46

I added my username to the group 'netdev', logged out and in again, and now everything went smoothly. Found this info on a Debian site.


On Ubuntu Gnome 15.10, I had the same problem, I selected the following options when Connecting

Fill: username: #yourusername anonymous identity: #yourusername

Inner authentication: MSCHAP (Not MSCHAPv2)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.