0

Ok, so I upgraded my 14.04 LTS headless server to 15.04 using ssh and cli. Had similar problem on boot (black screen) so I had thought "foolishly" that this would have been resolved in the latest release and did another upgrade to 15.10. Big mistake, I know.

Well, it's not completely bricked since I can boot into recovery mode and unlock my drive and proceed to boot but I am wondering if anyone knows if there is a known issue with this kernel and AMD drivers since it worked fine in 3.16.xx? I'm not doing anything graphics intensive so I'd rather not use any AMD proprietary drivers, it's a headless (no gui) server but I would like it to boot and get to the prompt for me to unlock the Luks encrypted drive at least.

Some data that may be helpful:

$ uname -r
4.2.0-18-generic

$ dmesg | egrep 'drm|radeon'
[    2.039343] [drm] Initialized drm 1.1.0 20060810
[    2.063777] [drm] VGACON disable radeon kernel modesetting.
[    2.063790] [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
[   25.984146] [drm] VGACON disable radeon kernel modesetting.
[   25.984162] [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
$ lspci | grep -i vga
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880 [Radeon HD 4250]

Saw this post here and Nephente commented that

The Wily kernel and the proprietary AMD drivers don't work together yet. – Nephente Oct 23 at 7:12

Well, I'm not using proprietary AMD drivers...that I know of.

I've tried setting 'nomodeset' in the /etc/default/grub to no avail. Can someone help get me to a point where I don't have to manually tell it to go to recovery mode every time I boot up? The only reason I upgraded is because my security scan found a TON of vulnerable out-of-date binaries in 14.04 even though it was fully patched (apt-get update && apt-get upgrade && apt-get dist-upgrade). That freaked me out so I upgraded to 15.X to get patched binaries without manually installing all of them.

Thanks!

  • This is a problem with the initramfs , not the kernel. Boot to recovery mode and run update-initramfs -u -k all – Panther Nov 18 '15 at 4:06
  • Thank you Bodhi, that seemed to have worked after a few reboots. Appreciate it! – YouDontNeedMyName Nov 18 '15 at 20:51
0

Comment converted to an answer as it worked..

This is a problem with the initramfs , not the kernel. Boot to recovery mode and run

update-initramfs -u -k all

Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.