22

I have an internal microphone in my laptop. I think it uses Intel High Definition Audio. But I can't get it to work with Ubuntu. It doesn't work with either the Sound Recorder or Skype.

On the Input tab in 'Sound Preferences', I just see Internal Analog Input Device...

3
  • I installed Ubuntu 12.04 and after this the in built microphone did not work. An external microphone was fine. I tried adding the extra line "options snd-hda-intel model=auto" to the "/etc/modprobe.d/alsa-base.conf" file but this made no difference. I resolved the problem very easily, as stated earlier in this thread. I installed Pulse Audio Volume control with the software centre and unlocked the left and right channels of the microphone. The icon is in the top righhand corner next to the mute icon. This worked but beware, the problem came back after using Skype. You have to stop skype from a
    – user139978
    Mar 13 '13 at 13:26
  • what ubuntu version?
    – user47206
    Mar 8 '17 at 14:06
  • This is a duplicate question of: Ubuntu 20.04 Lenovo Ideapad Microphone not working
    – galoget
    Jul 9 at 6:10
32

This is what I had to do to get the internal mic to work on my Acer Aspire 5745G:

  • Install pavucontrol:

    sudo apt install -y pavucontrol`
    
  • Run it with:

    sudo pavucontrol
    
  • Go to the "Input Devices" tab

  • Click the lock icon to unlock the channels

  • Set the right-front channel to silence

7
  • when I did this (though I use an Acer Aspire 5810TZ). It didn't work for me. But in the terminal I got this>>>>>>> daniel@daniel-Peter5o10:~$ sudo pavucontrol ** (pavucontrol:2805): DEBUG: Error reading config file /root/.config/pavucontrol.ini: No such file or directory ** (pavucontrol:2805): DEBUG: Failed to initialize device manager extension: No such extension Jan 3 '12 at 9:31
  • 1
    Last step: Then click "Set as fallback" to save, otherwise it will not work. Feb 22 '16 at 8:45
  • Just pressing the unlock button and then locking again worked for me. No idea how it worked though. Jan 14 '17 at 9:00
  • not working in 16.04 is it?
    – user47206
    Mar 8 '17 at 14:06
  • works in 16.04! Acer Aspire E1-572G with only 1 jack for headset. Just unlocked the channels.
    – spirit
    Mar 10 '17 at 9:51
11

I had the same problem, and fixed it thus:

If you go to the Ubuntu Software Centre and download the Pulse Audio Volume Control or from a terminal type:

sudo apt-get install pavucontrol

Then just run it with:

pavucontrol

And your microphone should show up there. If your microphone shows up but you're still not getting any sound, unlock the channels, and drop one of them down to zero. This worked for me, hope it helps you!

2
  • Did just notice the date of this post, my bad! Maybe this answer will help anybody who comes a-looking :P May 27 '12 at 2:39
  • It did! :-) Although I had to set it to slightly above 0 in order to see any amplitude.
    – bit-pirate
    Nov 26 '13 at 2:02
10

Add this line to your /etc/modprobe.d/alsa-base.conf file:

options snd-hda-intel model=dell-vostro enable=1 index=0
1
  • i had this problem in lucid and it was fixed out of the box on maverick Nov 8 '10 at 19:17
8

I know this might sound crazy, but go to the sound preferences, under input, and make sure the check mark for mute is unchecked, it is checked by default....

5
  • Its not crazy, its sensible. But I've already checked that.
    – User
    Oct 14 '10 at 1:03
  • Do you have an external microphone to test with? If so does it work?
    – TheXed
    Oct 14 '10 at 1:58
  • No.. Currently I do not have access to an external microphone to test my set-up.
    – User
    Oct 14 '10 at 5:06
  • 1
    I know it is crazy. Skype wouldnt work for me and I figured out that I had to uncheck this. I can't understand why it is set to mute as default!
    – Pasta
    Oct 19 '10 at 6:52
  • wow... it sounds crazy as you said. But the mute button it's really tiny and subtle in the preferences that I didn't notice it was activated (And no idea why it was activated without asking me). Thanks!
    – silgon
    Jul 29 '18 at 7:14
2

Open a new terminal and run the following commands:

sudo gedit /etc/modprobe.d/alsa-base.conf

Add these two lines to the end of alsa-base.conf:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

Save and reboot.

1

The solution given above it probably the right thing to do, I've encountered this problem several times at some friends. However, if you can't find it, it might be the case that Ubuntu detected the wrong default audio device. Which happens are various allocations.

If this happens, simply open the sounds manager and browse through the devices in the small menu at the top. Just try turn mute off for all of them and then I'm 100% sure that you will figure it out!

1
  • I have tried to select and test this for all my sound devices. The internal mic works with none.
    – User
    Oct 15 '10 at 1:51
1

If you have Fn keys on your keyboard, try enabling the webcam using the Fn keys. in my case the mic and the webcam are disabled and enabled by the same Fn key. I am not sure but you might have a separate Fn key for the mic.

0

In case solutions with pavucontrol did not work for you, try boosting your internal mic from alsamixer in a terminal. By default, it is set to zero, but boosting it resolved my problem.

0

I am running Lenovo Thinkpad with Ubuntu 18.04 and I'm connected to the lenovo Dock which may have affected the native headphone controls. Both headphone and headphone mic would not work.

I tried the top answer by Arpit Phillips:

  • Install Pavucontrol with:

    sudo apt install -y pavucontrol
    
  • Run Pavucontrol with:

    sudo pavucontrol
    
  • Go to the "Input Devices" Tab

  • Click the Lock icon to unlock the channels

and I was able to unmute my headphone there to hear sound, but the mic continued to not work.

Secondly, I tried the answer by User and oddly it worked in getting my mic working again.

  • Add this line to your /etc/modprobe.d/alsa-base.conf file: options:

    snd-hda-intel model=dell-vostro enable=1 index=0
    

I tested my microphone with https://www.onlinemictest.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.