2

I recently upgraded to 15.10 from 14.04 (15.04). I seem to have everything working OK but installing proprietary Nvidia drivers has proved beyond me.

I have tried all the available options in software updates (340 and 352) and also some from the graphics-drivers ppa however all lead to what I assume are Load Kernel Module errors before any log in screens appear. I can only resolve these by reinstalling nvidia-current (304) from a terminal.

I am running with Nvidia GT730M and Intel HD4000

What are my best options to resolve the errors? I would rather not have to do a clean reinstall (but I can if necessary). I apologise for the lack of information, this is my first question, although I have found many helpful responses here in the past.

If you need any info I will try to provide. Many thanks in advance.

3
  • what are the errors? – Goddard Nov 17 '15 at 17:10
  • Hard to tell, a screen which has a line saying [FAILED]Failed Load Kernel Module and sometimes just a flashing black screen, anywhere specific I can look for more info. – Hugh Williams Nov 17 '15 at 17:40
  • Have tried again with 355 and the boot just hangs at the Ubuntu splash, if I use recovery I can get to login but upon entering my password it just loops back to the login – Hugh Williams Nov 17 '15 at 17:52
0

Try this

sudo update-alternatives --set x86_64-linux-gnu_gl_conf /usr/lib/nvidia-352-prime/ld.so.conf
sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/nvidia-352-prime/alt_ld.so.conf

When you have the nvidia drivers installed. Obviously the versions should match.

Also you might have to boot into "recovery mode" when the GRUB menu is displayed and then when asked what you want to do just select resume normal boot.

At that point ctrl + alt + f1 then log in and then run those commands. You can make this easier by creating a .sh file and then just run that file rather then trying to enter this super long command.

10
  • I am running 64 bit do I only need to run the first line? – Hugh Williams Nov 17 '15 at 18:29
  • no you need to run both. – Goddard Nov 17 '15 at 18:30
  • Thanks for your help but it still just loops at login, message during recovery boot is 'Failed to start Load Kernel Modules' see 'systemctl status systemd-modules-load.service' for details – Hugh Williams Nov 17 '15 at 18:45
  • I have to run this command at every reboot. First I go into recovery mode and then I can boot normally upon rebooting. Do you get a lightdm screen(login screen) when you boot into recovery mode? – Goddard Nov 17 '15 at 18:48
  • I get to the login screen but when i enter my password it just flashes a screen of text too quickly to see and then goes back to login – Hugh Williams Nov 17 '15 at 18:53
0

These instructions were key to cleaning up my failed installation attempts until I got the process right.

sudo nvidia-settings --uninstall
sudo apt-get remove --purge nvidia*
sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv
sudo apt-get install nvidia-common
sudo apt-get install xserver-xorg-video-nouveau
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg

Then I updated my grub configuration thusly:

GRUB_CMDLINE_LINUX_DEFAULT="nomdmonddf nomdmonisw nouveau.modeset=0 rdblacklist=nouveau nomodeset"

It seems to work just as described in most guides - however most of my issues were due to boot/grub-config failures, which was due to issues with my MBR and grub. I suspect boot-repair might be useful for many others like me.

One install failed b/c I chose Yes to build with DKMS support, but something was wrong with my headers and/or source. I fixed this by changing to /usr/src and running

sudo apt-get install --reinstall linux-headers-$(uname -r)
sudo apt-get source linux-headers-$(uname -r) 

Once I was confident that I had a clean (non-nvidia) driver situation and that disabling nouveau was going to work, I proceeded with the installation of the downloaded driver:

sudo service lightdm stop
sudo modprobe -r nouveau
sudo sh [nvidia-installer].run

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.