1

After upgrading to Kubuntu 15.10 from 14.04, I've found that some programs get much slower or completely hang over the course of a few hours of use. (Even though I have 32 GB RAM, an SSD, and a fast 12-core CPU.) Examples:

Imagemagick operations, like "convert -resize '35%' largefile.jpg smallfile.jpg", simply hang. Likewise for "display largefile.jpg".

I run "geeqie" to view a directory full of photos. I press the down arrow key to move to the next photo. Nothing happens and geeqie is frozen for about 20 seconds, then it unfreezes.

Google Chrome slows down considerably and freezes frequently, then unfreezes. I visit a familiar web page and the scrollbar doesn't function for the first 10 seconds.

I run Terminal by pressing a hotkey I defined (alt-ctrl-T), and the window appears 15 seconds later, or not at all.

"top" says that nothing is hogging the CPU. "free" says I have 28 GB of free memory. My instinct says "blame Plasma or sddm."

The problems are intermittent. But when I log out of Plasma and log back in, and everything's fast again. For a while.

14.04 worked like a charm. Very frustrating!

Any tips appreciated!

0

Did you read this:

http://scarlettgatelyclark.com/2015/kubuntu-kde-5-4-3-bugfix-release-available-now-in-wily-backports/

I'm generally not a big friend of ppa's, but there is actually no other way to receive bugfixes for Kubuntu than using the backports-ppa. Well 14.04 had KDE4 and it's an LTS. Any STS get's only 9 month support, so anyone is taking part in development to a stable release. I have a LTS+ a STS on the PC (that way it's not too frustrating. After Trusty Kubuntu enters a new Aera with Plasma-KF5 & Applications-KF5. Some edges and corners have to be expected in my mind :-) The good thing about the backports-ppa is it will not hinder a system update lateron, as it doesn't contain newer versions than in the next release.

edit2: Upon the answer that this didn't change a lot, I suggest U take a look a the installed Java-Version

$ java -version

If it's OpenJDK-7, just install OpenJDK-8.

Background: Could as well be this bug (see also bug-duplicates there):

https://bugs.launchpad.net/debian/+source/openjdk-7/+bug/1512760 title: Java applications leaks shmem chunks

edit3: Just forget my last comment, bugfix was published to the masses yesterday.

3
0

The problem appears when running VMware Workstation 12 at the same time as graphics programs like geeqie or ImageMagick display. It is solved by disabling transparent hugepages in the kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.