15

I did a few quick google searches, and it looks like the most recent discussion about this was back in 2012.

How might I go about disabling mouse acceleration in Ubuntu 15.10? I tried installing gpointing-device-settings but there were many errors.

I'm looking for a persistent setting.

1
11

The following (stolen from r/linux_gaming) seems to work:

sudo vim /usr/share/X11/xorg.conf.d/90-mouse.conf

and paste inside this:

Section "InputClass"
    Identifier "mouse"
    MatchIsPointer "on"
    Option "AccelerationProfile" "-1"
    Option "AccelerationScheme" "none"
EndSection
5
  • 1
    Great, thanks! It works perfectly. I never thought to check r/linux_gaming. – Pheonix Dec 8 '15 at 22:36
  • 8
    Forcing mouse acceleration with an update and providing no means to disable it is nota good move on Ubuntu's part... Thanks for this. – Nepoxx Dec 22 '15 at 16:37
  • 1
    Do I need to restart? I'm not sure the acceleration is off. – AlikElzin-kilaka Jul 21 '16 at 15:03
  • 3
    Didn't work on 16.04 after restart. Even when adding Option "AccelSpeed" "-1" as stated here – AlikElzin-kilaka Jul 21 '16 at 15:21
  • Interesting. I updated my machine to 16.04 and the fix carried over. – Pheonix Jul 21 '16 at 17:05
17

You can make it nice and simple simply by running:

xset m 00

Which will completely turn off mouse acceleration.

!#/bin/bash
xset m 00

Save the file as a .sh script - make it executable with chmod +x filename, add it as a startup program in the Startup Applications program, and you're good to go!

1
  • 2
    This is a great example of how to add startup scripts. Thanks! – Pheonix Aug 25 '16 at 1:40
7

There is a GUI for this, gpointing-device-settingsInstall Gpointing device settings:

sudo apt-get install gpointing-device-settings 

GPointing Device settings dialog This program has several features missed in the standard gnome-mouse-properties configuration dialog, like advanced touchpad scrolling settings. If all you need is to adjust acceleration settings, use gnome-mouse-properties instead.


If you seek for CLI way, xinput will be to your usage.

3
  • On Ubuntu 16.04 getting Package gpointing-device-settings is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source – AlikElzin-kilaka Jul 21 '16 at 14:55
  • 1
    Found a way to install it here: askubuntu.com/a/783234/13330 – AlikElzin-kilaka Jul 21 '16 at 16:08
  • 2
    Mind this is 6 year old screenshot. 12 Ubuntu releases ago. – ulidtko Mar 20 '17 at 3:45
4

I find the pointer acceleration extremely annoying. Even when it's set to "low"

Edited as the link is dead.

Find you input devices

xinput list

List current properties for the relevant id

xinput list-props <id>

Change the mouse pointer speed (non persistent)

xinput set-prop 'Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)' 'Device Accel Profile' -1
xinput set-prop 'Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)' 'Device Accel Constant Deceleration' 2

Setting Device Accel Constant Deceleration to 1.5 gives a slightly faster mouse.

To make the changes permanent, add the changes to a file and executed them automatically at login. Some options can be added to the x-server config.

More details here: https://www.x.org/wiki/Development/Documentation/PointerAcceleration/

0
3

install package xserver-xorg-input-libinput:

apt-get install -y xserver-xorg-input-libinput

and reboot.

2
  • This looks interesting. One of the previous answers fixed my issue, but I might give this a shot. – Pheonix Aug 25 '16 at 1:53
  • +1 It works fine for me, with Ubuntu 15.10 64bit and mouse "MOSART Semi. 2.4G Keyboard Mouse" (Wisdomcreate ET 2.4GHz) – user2342558 Mar 23 '17 at 9:13
1

Solution found there : https://ubuntuforums.org/showthread.php?t=1734400&s=ca88cf7a66bc549b9b504f155e287f53&p=10995493#post10995493

use xinput -h in terminal for a list of xinput commands

we want: xinput list which will display input devices with their device ID in brackets

and then xinput list-props # where # is the device name or device ID. this lists configurable device settings and their numerical ID in (brackets)

then use: xinput set-prop deviceID settingID value replacing deviceID and settingID with their corresponding numerical values, and value with the new value you wish to set for the variable. (ie. -1 for AccelProfile)

you can then test this has worked by repeating: xinput list-props deviceID

For me it's :

xinput set-prop 12 265 -1

If it's working, put this command into a script to be executed at each session start.

1
  • I prefer the method of editing the standard config files. Making a script to run at session start seems silly; even if I don't have to reconfigure it manually, why have it reconfigure at all? It should get configured correctly the first time. I guess it ultimately doesn't matter. – Pheonix Aug 3 '16 at 16:56
1

A much better way to do this and one which resists to sleep, hibernation, etc is this:

First run

xinput list

This will give you a list of devices, which looks like this:


⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ A4Tech USB Mouse                          id=11   [slave  pointer  (2)]
⎜   ↳ GASIA USB KB V11                          id=13   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=16   [slave  pointer  (2)]

Find you device's name and take note (mine is A4Tech USB Mouse).

Create a file in /etc/X11/Xsession.d/ called 99disablemouseaccel

sudo nano /etc/X11/Xsession.d/99disablemouseaccel

Paste the following contents inside it:

xinput set-prop "A4Tech USB Mouse" "Device Accel Profile" -1 &>/dev/null
xinput set-prop "A4Tech USB Mouse" "Device Accel Velocity Scaling" 1 &>/dev/null

Now save it. These commands will be run whenever an X session starts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.