To developers and administration :)

I am developer so my work depends on OS on which I work.

  1. As additional software I installed Unity2D desktop from repository and OpenBox.
  2. A couple a days ago, when I was working on UNITY_2D, I got the upgrade proposal notification, so I agreed, and the update of my system begun.
  3. The update was successful, I turned on my Notebook, then login, but after a couple of minutes borders on my windows disappear. Even if I reload Unity, they continue to disappear each time after a couple of minutes.
  4. A couple of days after (I am not sure how many days exactly), I tried to login to my user - I enter password (password is right) -> Black screen with codes for 2-3 seconds -> And I am again on login screen. I tried all desktops manager and "CTRL ALT F1" Terminal: user login is possible only on Terminal sessions, but it do not load Visual desktop.
  5. 'Guest' User is working with any desktop, on "root" user I can't login because my password didn't work.

I really like Ubuntu and I understand that developers work a lot of time to bring us a new design and features in 11.10 distro, But after upgrade --- All my system goes to HELL, and my work too.

  • 1: was unity-2d installed in your 11.04 or 11.10? I ask because the package is now installed by default in 11.10. 4: what happens if you run Unity from Terminal sessions? – igi Oct 20 '11 at 23:15
  • 1) Unity2D was installed in 11.04 --- 4)From terminal I can enter as My User, but visual desktop (Unity) is Disabled, so I can use only commands as in simple terminal. – ARON Oct 22 '11 at 1:11

From what I can gather I would check to see if your PATHs have been corrupted somehow. It's possible that GDM or gnome-session are not within the paths of the users for some odd reason. I've noticed that Ubuntu has a strange way of randomly taking PATHs out of most configuration files whenever you change things.

Check what you get on: echo "$PATH"

It's one of the gotchas that's plagued me even without an upgrade.

  • I enter command - echo "$PATH". Then I get this - /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games – ARON Oct 21 '11 at 17:21

Have you tried creating a new user and seeing how that works? If that works ok, one option would be to move all the hidden files and folders in your home directory to a backup folder.

Another thing to check with login problems is that your home directory permissions haven't somehow been changed.

  • I try next variants: 1) Login as GUEST -> Not enought privileges to create user, SUDO command do not work. 2) CTRL + ALT + F1 -> In terminal I login from my user and try commands "useradd" and "useradd -m -s /bin/bash userName" , after that I get error message - some sord of "Can't lock directory" – ARON Oct 21 '11 at 17:06
  • Just as an aside, I believe it's better to use "adduser" than "useradd". It's a bit higher level and safer. That won't work as a guest, because the guest won't have root privileges. Not sure why the second option didn't work though. – Alex Oct 22 '11 at 6:17

I found a solution. ( It's really working and not a joke )

1) Download "Ubuntu 11.10" from official site.

2) Create Live CD or Live USB.

3) Reboot PC -> Start install process -> In the menu chose option UPGRADE UBUNTU TO 11.10.

4) After UPGRADE , all will be working.

After upgrade all data will be saved, and all will be working.

There is some problems with sites on XAMP , but easily can be fixed by changing chmod rights to folders.

The problem was actually very simple -- in "home" directory was 0 bytes of free space, that's why user do not load.

PS: I tried all methods that i found on the internet spend two days for this problem, especially on ubuntu forums - but not one is not working for me, UPGRADE IS THE BEST solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.