1

I cannot change my display resolution to correct one. It is not in the resolutions list in the display settings. I really searched my problem but I could not solve. My monitor's resolution is 1680x1050 (16:10) but there is other 16:10 resolution in the list too.

Also I cannot see the edge areas of display, they are like outside of my monitor. But when I changed display from "Full" to "16x9" from monitor's own settings I could see the bottom and top with 1280x1024 setting. If I change this resolution (for example 1280x720) bottom and top edge goes outside slightly. But after using following code I could see right edges if I move my mouse to edge. I mean display moves to right. (Actually a value like 1350x1024 works too. Lower value = lower black area on the right)

xrandr --fb 1680x1024

Images to explain better: http://imgur.com/a/6t72w

OS: Xubuntu 15.10  
My monitor: BenQ FP222 WH  
Graphics Card: Nvidia GeForce GTX 770

I am using HDMI cable from graphics card to monitor. If I connect HDMI cable to socket in the motherboard instead graphics card, I see nothing in the monitor. Even UEFI (or BIOS) image.

I also installed Nvdia Driver version 352.41 from additional drivers.

And my tries:

    maydin@maydin-desktop:~/Desktop$ xrandr
Screen 0: minimum 8 x 8, current 1280 x 1024, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 470mm x 300mm
   1280x720      60.00 +  60.00    59.94    50.00  
   1920x1080     60.00    50.04  
   1280x1024     75.02*   60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
   624x464       59.95  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
maydin@maydin-desktop:~/Desktop$ cvt 1680 1050
# 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
maydin@maydin-desktop:~/Desktop$ xrandr --newmode "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
maydin@maydin-desktop:~/Desktop$ xrandr --addmode HDMI-0 1680x1050_60.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40
maydin@maydin-desktop:~/Desktop$ 

When I try these codes with Ubuntu live without install addmode works. I saw 1680x1050 in the list but result was not good. I could not see my whole display.

Other display stuff here

lspci | grep -i vga

maydin@maydin-desktop:~/Desktop$ lspci | grep -i vga
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 770] (rev a1)

lshw -C video

maydin@maydin-desktop:~/Desktop$ lshw -C video
WARNING: you should run this program as super-user.
  *-display               
       description: VGA compatible controller
       product: GK104 [GeForce GTX 770]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:30 memory:f6000000-f6ffffff memory:e8000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

glxinfo | grep render

maydin@maydin-desktop:~/Desktop$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce GTX 770/PCIe/SSE2
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_NV_compute_program5, GL_NV_conditional_render, 
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_NV_compute_program5, GL_NV_conditional_render, 
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
    GL_EXT_render_snorm, GL_EXT_robustness, GL_EXT_sRGB, 
    GL_NV_conditional_render, GL_NV_copy_buffer, GL_NV_copy_image, 
    GL_NV_path_rendering, GL_NV_pixel_buffer_object, GL_NV_polygon_mode, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 
0

All problem comes from HDMI. Drivers do not support this monitor. Because of that you should use DVI cable.

Both Windows and Linux with both ATI and Nvidia i could not receive good display.

0

I had a similar issue with a GT 730 graphic card and here is a way around :

1/ Go to www.nvidia.com -> support -> download drivers

2/ enter particulars of your card to find the appropriate driver (in the case of the GT 730 it is 361.28

3/ if you are experimented user install the driver and go to 6/

4/ if not, go to your "system and parameter" in the dash, select "programs and updates", and "additional drivers"

5/ use the closest driver "352.63" and install it by using "apply"

6/ once installed, you have a new application "nvidia settings"

7/ navigate in the application to find "underscan". Set a value to match your display (in my case 43 would fit)

8/ that's done

0

A workaround when xrandr fails consists in forcing a resolution from the GRUB menu:

  • Start your computer and hit Esc in order to have access to the GRUB menu, then press C to go to the command line.
  • At the command line, type vbeinfo and hit Enter. You'll get a list of supported resolution modes. Take note of the highest one, which will be your "desired mode" (for instance: 1280x768x32, which means 1280x768 resolution and 32-bit color depth). Also take note of the one you wish as fallback mode (for instance: 800x600x4), then hit Esc to return to the GRUB menu, select the option that boots your Linux distribution (it's usually the first/top option) and hit Enter.
  • After your login to the GUI (graphical user interface), start the shell terminal and execute sudo nano /etc/default/grub (if your system doesn't have the Nano text editor, just execute sudo apt-get install nano -y and afterwards execute sudo nano /etc/default/grub again), then replace the #GRUB_GFXMODE=640x480 code by the one below (lines starting with # are interpreted as comments, thus removing the # character makes such lines become parameters that are interpreted by GRUB). Notice that this is just an example, but the first resolution and color depth (to the left) must be the highest mode you saw on the list generated by vbeinfo and the second one must be the "fallback mode" you picked from the same list:

    GRUB_GFXMODE=1024x768x32,800x600x4,auto
    GRUB_GFXPAYLOAD_LINUX=keep
    
  • Once the code is modified like the above example, use the Ctrl O key combo (press the O key while holding the Ctrl key) in order to save the file, then use the Ctrl X key combo in order to exit Nano. Subsequently, execute sudo update-grub (in order to apply these changes to the GRUB config file) and then restart your system (so the changes will take effect).

If KMS (kernel mode setting) works, GRUB will ask the Linux kernel to initialize the display driver following the hierarchy you previously defined.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.