0

sorry for bothering everyone. But I've been having some problems with my lenovo thinkpad recently.

This suddenly happened this morning and now I can't get it back to normal. For example, when I press the left shift button and 2, It comes up as @, for an email address instead of a " for an open speech marks. The " is where the @ should be instead. Also, the ~ is where the | is. I've tried searching around the internet and it appears that I might have accidentally activated Numlock. I've tired to look up how to disable it,but no luck.

I have ubuntu 14.04, please put your criticism on how stupid I am down below, it's just I'm a beginner at this kind of stuff.

0

I assume you somehow managed to change the keyboard settings. There are several methods to correct this depending on which desktop you use. I'll explain you the method involving the terminal (that's the black screen with white characters). So:
Open a terminal (or konsole, depending on your desktop flavor). Then type this command in the terminal
sudo dpkg-reconfigure keyboard-configuration and then press the enter key.
You'll be asked a few questions and be sure to choose the applicable answers. Most likely your keyboard is a generic type with a US layout. After answering the questions please restart the computer and then the keyboard should work correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.