0

I have 14.04, installed with 3G main disk, 8GB memory. I initially tried to set it up as a DHCP server, but gave some bad configuration data and it lost eth0 connection. Upon reboot, the NetworkManager icon in the system try does not exist. If I attempt to go to "System Settings" and select the Network icon. I receive an error message that it's a version problem. I've taken a couple of screen shots so you can see the displayed results of items.

I've removed and re-installed the NetworkManager. When I execute the 'nmcli con' one of the lines mentioned is

Ethernet 0 5620e493-5125-48e3-a3c4-6e35fe351a07 802-3-ethernet Wed 11 Nov 2015 08:58:15 PM MST

This timestamp is at least 5 days old, and is my main connection out of this box. I'm starting to wonder if it's really working or something else is running instead. Since I'm on here with it, this is working and no other connections are valid. Any suggestions would be appreciated.

Screen shot with missing NetworkManager icon - while connected. Error message from NetworkManager with version problem.

  • Does the Network Manager icon appear if you do, in a terminal: nm-applet &? Does an error or warning appear in the terminal? – chili555 Nov 17 '15 at 0:54
  • Chili555, I now, after removing and re-installing NetworkManager, the icon. It's just an empty pie shapped outline. I am now connected and the system try only has an pie section. If I click on the icon then on "connection information" I get "No active connections found". This says someone else (not NetworkManager) is handling my comm links elsewhere. I do seem to be able to reload everything with '/etc/init.d/networking restart', does seem to restart. I guess they are different animals? – user65913 Nov 18 '15 at 14:03
  • May I see: cat /etc/network/interfaces Thanks. – chili555 Nov 18 '15 at 14:05
  • Here is the output. I've been over all of this, but I appreciate someone else looking at it. Here is the output: auto lo iface lo inet loopback auto eth0 iface eth0 inet static address 192.168.1.66 gateway 192.168.1.1 dns-nameservers 192.168.1.65 208.67.222.222 208.67.220.220 broadcas 192.168.1.255 netmask 255.255.255.0 – user65913 Nov 19 '15 at 18:19
  • Is there some way to enter longer information? this limit is rather useless. – user65913 Nov 19 '15 at 18:29
0

Network Manager will not manage interfaces that are declared in /etc/network/interfaces. Your will appears to have some questionasble entries. I suggest you amend it to:

auto lo 
iface lo inet loopback 

auto eth0 
iface eth0 inet static 
address 192.168.1.66 
netmask 255.255.255.0
gateway 192.168.1.1 
dns-nameservers 192.168.1.65 208.67.222.222 208.67.220.220

Is 192.168.1.65 the correct DNS nameserver? If in doubt, remove it altogether or check other devices on the network. Restart the interface:

sudo ifdown eth0 && sudo ifup eth0

Check:

ping -c3 192.168.1.1
ping -c3 www.ubuntu.com
| improve this answer | |
  • The sudo ifdown... Executes with no errors. The pings work and end with 100% complete, no loses. If interfaces should not be configured, do I just delete it? (I'll try that, of course just rename it). It still claims that I'm not connected. – user65913 Nov 21 '15 at 2:42
  • But are you actually connected? We know you can ping. Can you sudo apt-get update? Can you reach this forum with Firefox? You can just keep the settings in /etc/network/interfaces and ignore or even remove NM, or you can remove all the eth0 lines from the file and let NM manage networking. – chili555 Nov 21 '15 at 21:21
  • Yes I'm connected, reading e-mail (gmail) and searching for answers. I have tried to rename the interfaces file, but it doesn't seem to make any difference. I do like to use a GUI when I can for some things, like management of my VPN lines. I haven't been able to use it (VPN) for a couple of weeks now. – user65913 Nov 23 '15 at 9:18
  • No, you mustn't rename the file. Simply comment out all the eth0 lines like this:#auto eth0 and continue for all. Be certain to leave the lo loopback lines unchanged! Restart NM: sudo service network-manager restart Now NM should manage eth0. – chili555 Nov 23 '15 at 14:44
  • I will try your approach. I renamed it, rebooted, ended up manually configuring the comm. I have also done an apt-get purge network-manager and re-booted and re-installed. I will try what you suggest and report back. – user65913 Nov 24 '15 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.