Is there any way to stop touchpad moving my mouse but still have buttons working with libinput (ubuntu 15.10 with xserver-xorg-input-libinput)? The same effect used to be achieved with setting AreaTopEdge=9999 in synaptic.

my env:

xinput 
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=14   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=10   [slave  keyboard (3)]
    ↳ Rapoo Rapoo Wireless Audio                id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=15   [slave  keyboard (3)]
root@localhost:/usr/share/X11/xorg.conf.d# xinput list-props 13
Device 'SynPS/2 Synaptics TouchPad':
    Device Enabled (142):   1
    Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (279): 0
    libinput Tapping Enabled Default (280): 0
    libinput Tapping Drag Lock Enabled (281):   1
    libinput Tapping Drag Lock Enabled Default (282):   0
    libinput Accel Speed (283): 0.000000
    libinput Accel Speed Default (284): 0.000000
    libinput Natural Scrolling Enabled (285):   0
    libinput Natural Scrolling Enabled Default (286):   0
    libinput Send Events Modes Available (263): 1, 1
    libinput Send Events Mode Enabled (264):    0, 0
    libinput Send Events Mode Enabled Default (265):    0, 0
    libinput Left Handed Enabled (287): 0
    libinput Left Handed Enabled Default (288): 0
    libinput Scroll Methods Available (289):    1, 1, 0
    libinput Scroll Method Enabled (290):   1, 0, 0
    libinput Scroll Method Enabled Default (291):   1, 0, 0
    libinput Click Methods Available (292): 1, 1
    libinput Click Method Enabled (293):    1, 0
    libinput Click Method Enabled Default (294):    1, 0
    libinput Disable While Typing Enabled (295):    1
    libinput Disable While Typing Enabled Default (296):    1
    Device Node (266):  "/dev/input/event4"
    Device Product ID (267):    2, 7
    libinput Drag Lock Buttons (297):   <no items>
    libinput Horizonal Scroll Enabled (268):    0
    Synaptics Off (501):    2
    Synaptics Tap Time (742):   1000

Please note there is no Synaptics Finger property. I hoped that setting it to 100 release, 1000 touch, 200 press would solve my problem, but no luck...

  • Did you solve this problem yet? I’m very interested in a solution. I tried setting acceleration to -1 but it doesn’t disable movement either. Though it makes movement much slower so it might help a bit. xinput set-prop "SynPS/2 Synaptics TouchPad" "libinput Accel Speed" -1 – Michael Dec 6 '15 at 11:07
  • No, but I found that it's possible to disable it in BIOS. Buttons still work. I tried to apply all sorts of options found on x.org/archive/X11R7.5/doc/man/man4/synaptics.4.html, like "xinput set-prop --type=int --format=8 13 "Synaptics Finger" 50 90 255" but no effect at all – Евгений Бушуев Dec 7 '15 at 11:27
  • Short update: I managed to disable movement quick&dirty in source code. I uncommented line 920 (tp_motion_history_push(t)) in libinput 1.0.3’s evdev_mt_touchpad.c, then built and overwrote the existing libinput .so file. – Michael Dec 16 '15 at 10:03

Based on Michael's comment on your question from Dec 16 '15, I built a script which patches and installs libinput in order to entirely disable touchpad movements. The script is available from https://github.com/faf0/thinkpad-scripts/blob/master/16.04/libinput-disable-touchpad-movements.sh. Simply clone the github repository and then execute the libinput-disable-touchpad-movements.sh script to carry out the installation. Unfortunately, I did not find a way to set the xinput properties of the touchpad to achieve the same result.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.