0

This question already has an answer here:

First of all I would like to say Thank you to anyone who tries to help me with this issue.

Second - I am not a *nix user at all, I really wish I had much more experience with this system, but unfortunately I have none.

Now back to my trouble - PREAMBLE (Feel free to skip to AMBLE) - Couple of months ago I installed Ubuntu 14.04 on my laptop, just to get some experience with it. I installed Mono+MySql and did some .Net development for a while as I am no Python or Java developer right now. I have no idea why, but my Ubuntu installation was bound to update center in my country (it is Georgia, small but lovely place) and as I gather this Update Center was not getting all the updates, or may be it was holding only important ones. So I had trouble with all those sudo apt-get ... commands all the time.

And here comes the AMBLE - Couple of days ago I encountered an article on updating Ubuntu version, which required no more than running update-manager and switching to US update center and getting all those updates, including Ubuntu 14.10.

So I did all those updates, but I am not sure if I got 14.10 version, as when I logged into the system the background wallpaper still said it was 14.04. Anyway, then I ran 15.04 upgrade.

Fact 01 : After spending several hours of trying to get into the system I already know that it was bad idea to upgrade 14.04 to 15.04.

During the upgrade to 15.04 my system just stuck at starting MySQL service, as many others did. I waited for couple of hours and then I just shutdown the machine as I had no other idea what to do with it.

As you may already have guessed I cannot get the system alive any more. The system boots up well, but when entering the password it displays some console text screen for a short time and sends me back to the login screen again. Unfortunately it is too fast to get any information out of it.

What I have tried so far

  1. Try to load the older versions - Restart, hit Shift, select Advanced Options select other boot options - same effect in any of them.

  2. Get to GRUB configuration screen, but unfortunately I have no idea what to do there.

  3. Get to console screen out of boot options menu - same effect.

  4. I've found USB Bootable drive from which I've installed 14.04, and tried to run boot-repair tool from it, no effect...

  5. Right now I try to do some silly things, but that's all I can do, unless someone with better knowledge of the system can help me - I ran 'update-manager' in a live session system loaded from flash drive, just hoping for the best - that it would make some changes to the existing system on my hard drive.

I do not need to save any data from my laptop, I just do not want to reinstall it, I really want to make it work. Any help would be appreciated, thank you all in advance.

marked as duplicate by Zanna, karel, Eric Carvalho, Fabby, waltinator Mar 18 '18 at 15:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Assuming you have another computer, just download 15.10 Version from www.ubuntu.com, burn it to an USB using unetbootin http://unetbootin.org/, and boot your Ubuntu-PC with the USB plugged in. On the Ubuntu installation, choose the option "Upgrade".

enter image description here

This will keep all your files and upgrade your whole system.

If you cannot boot from the USB, change your boot settings in the bios.

Hope it helps.

Regards

  • Ok, I'm having trouble with "upgrading", the installation says that my computer "has no detected operating systems". This might be because I have selected "Encrypt" option for the previous installation? However I can access the data from "Try Ubuntu" option, by specifying security key... Is there any way to get my old system upgraded? – GSazheniuk Nov 16 '15 at 16:57
  • It might be, but since you do not need to save any data from the laptop, wouldn't it be better to just perform a fresh install from Ubuntu 15.10? – Eduardo López Nov 17 '15 at 16:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.