1

My dell XPS 13 2015 with Ubuntu 14.04 is connected to an HDMI device via a displayPort -> HDMI adapter.

The picture appears fine on the HDMI monitor but I cannot select it as my output audio device. It doesn't appear in the system settings sound tab - only built in audio.

What can I do to fix this?

1

First, be aware for that display port to HDMI does not always transfer sound. Everything in your setup must be able to use DP for sound, even the adapter. Not all DP adapters will transfer sound. That being said, try alsamixer in terminal and change the settings there. If that does not work run sudo apt-get install pavucontrol and change your audio settings through there.

0

This helped me in Kubuntu: https://askubuntu.com/a/519113

You can use pavucontrol (pulseaudio volume control, install if necessary). Launch it from multimedia menu, go to the "output devices" tab, and click the green "define as alternative" button that is near HDMI soundcard.

Altho' I had to set the actual HDMI port as a sound device in 'output devices'. I also when to the 'configuration' tab & set it there. Then right-clicked on the speaker icon (KMix in Kubuntu) & selected 'select master channel' & changed it to HDMI there also.

Most likely the last one that fixed it for me (KMix).

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.