0

I got an error while installing Android studio.

The following SDK components were not installed: source-23, extra-google-m2repository and platform-tools

Retry didn't work, so I canceled and clicked on Configure > SDK Manager. It asked me to specify SDK location, although I specified it in the begginning. I clicked Edit and chose pre-specified location and clicked Next > Next.

Got same error.

  • see if useful – Ravan Nov 15 '15 at 13:02
  • May be I should run $sudo ./studio.sh I will check after all my downloads are finished.. – Tahir Imanov Nov 15 '15 at 13:06
  • Don't use sudo to run Android Studio. – A.B. Nov 15 '15 at 15:58
  • @A.B. - why? I already did and it worked... – Tahir Imanov Nov 15 '15 at 18:50
0

In the terminal, run these two simple commands to install a fresh copy:


sudo apt-get install ubuntu-make
umake android


Interact with the terminal whenever prompted. You can then launch your IDE with this command in the terminal sh /home/[user]/tools/android/android-studio/bin/studio.sh. Then, you can also learn how to create a .desktop file to run the same command outside terminal. Hopefully, this will get you out of the ocean.

Important

  1. Replace [user] with your username, e.g., john.
  2. If the solution does not solve your problem, let me know by comments.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.