3

First I zeroed out the entire USB flash drive:

dd if=/dev/zero of=/dev/sdb

And then I used fdisk(8) to create a type c W95 FAT32 (LBA) partition on it and formatted the partition as FAT32:

mkfs -t vfat /dev/sdb1

And then I used Ubuntu Startup Disk Creator to make it a bootable Ubuntu USB stick (the .iso file is verified and not at fault). However, whenever I use the drive to boot I get a Boot error message. What's going wrong? How to fix this? Edit: No other distributions (Fedora, Debian, etc.) on other bootable USB disk creators (UnetBootin, etc.) work. The tool runs on Ubuntu 15.10; the file used is of Ubuntu 15.10.

  • Version 15.10? (I just recently came across a bug for this, I can dig out the bug report and I think there's a fix in there but I should probably make sure it's 15.10 that you're using, first.) – KGIII Nov 15 '15 at 12:56
  • @KGIII Yes, this is on 15.10 – ThePiercingPrince Nov 15 '15 at 13:12
  • Looks to be in triage status. Even though it says 'beta' in the description - it appears to have made it through. Check here and specifically response #23. – KGIII Nov 15 '15 at 13:31
5

Ubuntu Startup Disk Creator is sometimes buggy. Use dd command instead.

sudo umount /dev/sdb1
sudo dd if=/path/to/ubuntu.iso of=/dev/sdb bs=4M; sync

Wait for it to write to the device. That's it. Here bs refers to Byte Size

  • 1
    formatting the first partition to vfat beforehand is completely useless, since you overwrite the whole device with dd. – user1514631 Dec 23 '15 at 16:44
  • can also create bootable usb without bs=4M; sync in above command. this is not compulsory... it is worked in my case . – d a i s y Jan 1 '16 at 4:14
  • 1
    @Linux yup. but bs speeds things up – Gayan Weerakutti May 15 '16 at 14:36
  • I prefer add status=process at the end of command : sudo dd if=pat_to_.iso of=/dev/sdb bs=4M status=progress – vanduc1102 Dec 3 '16 at 17:14
4

Use built-in Disks tool (gnome-disk-utility) to create the Ubuntu installation media properly.

Open Disks - select Restore Disk Image from the menu on the top right.

Choose the ISO file and the USB drive to write it to and start restoring.

  • My computer uses BIOS. I have tried this. Every time I plug the USB drive in and boot, it's stuck on the BIOS POST screen. – ThePiercingPrince Nov 15 '15 at 13:59
  • @ThePiercingPrince : Every computer has a Basic Input Output System - Did you change the boot order to boot from USB ? - Did you try another USB drive ? :) – cl-netbox Nov 15 '15 at 14:02
  • Yes, I have tried another USB drive. I can't go into the BIOS settings, the computer is stuck. – ThePiercingPrince Nov 15 '15 at 14:05
  • @ThePiercingPrince : On many machines you can select where to boot from by pressing one of the F keys e.g. F8 or F10 or F12- please try this. :) – cl-netbox Nov 15 '15 at 14:09
  • I have tried that, my computer's boot menu key is normally ESC. This is what happens on my computer when I try to boot from the created USB key: 1. I plug the USB drive into the USB port, and then turn on the computer. 2. After a beep, the BIOS screen shows. I tried all keys, including ESC, F8, F12 and others but nothing happens. If I leave the computer on it's own, the BIOS screen just stays there, forever. This doesn't happen without the USB drive. – ThePiercingPrince Nov 15 '15 at 14:12
-3

You have formatted it from FAT32 and FAT32 is only for Windows/MS-DOS booting and not Ubuntu, so zero it again but choose EXT3/4 and make the Ubuntu Startup Disk again and boot from USB.

  • 5
    This isn't right. Formatting fat32 is correct – Zanna May 15 '16 at 14:46
  • 1
    @Zanna is right as always :) – WinEunuuchs2Unix Jan 1 '17 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.