2

I have a Windows 10 on my Toshiba P50-B notebook. After installation and reboot, the machine boots into windows without showing boot options. I read a lot about Ubuntu and UEFI and made sure that:

  • W10 fast startup is off
  • I boot the USB install. media in UEFI mode (initial ubuntu menu is textual, not graphical)
    • i turned secure boot off in bios

While installing, i made sure, that ubuntu chose the EFI partition. When i click "change" on it, it was selected as EFI boot partition. I used boot repair disc afterwards, but didnt help me too. where can be the problem?

thanks!

  • Give the output of lsblk -f. So we could give specific instructions to repair grub. – Gayan Weerakutti Nov 15 '15 at 13:20
1

As you described in your question you already disabled Fast Boot in Windows ... please re-check !

You have to disable hibernation as well - open command prompt as administrator and execute :

powercfg /h off  

Now shutdown the machine completely - do NOT reboot !

Boot into BIOS and select Ubuntu in UEFI settings to be the default operating system to boot.

In case the GRUB boot menu doesn't appear when starting the computer :

Reinstall the GRUB boot loader to your Ubuntu installation in EFI mode.

Boot from the Ubuntu installation media - open a terminal and execute:

    sudo mount /dev/sd*** /mnt
    sudo mount /dev/sd** /mnt/boot/efi
    for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
    sudo chroot /mnt
    grub-install /dev/sd*
    update-grub  

Note:

sd* = disk | sd** = efi partition | sd*** = system partition

To check and verify the partition numbers use GParted (included in the Ubuntu install media).
Boot into BIOS and select Ubuntu in UEFI settings to be the default operating system to boot.

  • +1 for for i in : ) Why is it necessary to bind both /dev and /dev/pts? Mounting /dev would mount dev/pts also right? – Gayan Weerakutti Nov 15 '15 at 8:59
  • @reversiblean : The commands are taken from : help.ubuntu.com/community/Grub2/… :) – cl-netbox Nov 15 '15 at 9:06
  • Unfortunatelly, it didn't help. I disabled hibernation, than setting Fast Boot option in Windows disappeared, i hope its disabled than. Than I executed the commands you proposed. No error message. Group said linux kernel found, windows boot efi found, addind linux .... I dont see any option in BIOS to select ubuntu. i can only choose if i want boot mode UEFI, or CSM – george Nov 15 '15 at 10:20
  • @george : You are very close to get it working. - There must be an option in BIOS ... maybe you have to enable or switch something before - I saw this in other cases as well ... so please search and try again ! :) – cl-netbox Nov 15 '15 at 10:30
  • In my TOSHIBA P50-B-10P thre is really no BIOS option regarding UEFI other than to choose btw. UEFI and CSM. I checked with efibootmgr and the boot order was wrong. Windows was before ubuntu. I changed the order and rebooted - > black screen. Tahn i turned the pc off. When i turned it on, windows booted again. When i checked the boot order later, it was again like before with windows before linux. – george Nov 15 '15 at 17:21
0

SOLVED: You're right, its a hardware thing. My BIOS doesn't implement UEFI in the right way. It ignores EFI entries and always boots the same entry - bootx64.efi , see UEFI machine doesn't boot Ubuntu through NVRAM bootcatalog. How to fix? . So i manually created efi image for ubuntu with grub-mkimage and create grub.cfg as described in the link i pasted here (without the last menuentry). Now everythings ok! i can boot both ubuntu and windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.