9

I've updated the kernel to 4.3.0, but the driver still seems to be off. What else can I try?

starfall@nx ~ $ IBGL_DEBUG=verbose glxinfo
name of display: :0
i965_dri.so does not support the 0x1912 PCI ID.
libGL error: failed to create dri screen
libGL error: failed to load driver: i965

starfall@nx ~ $ sudo lspci -k | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Device 1912 (rev 06)
  Subsystem: Gigabyte Technology Co., Ltd Device d000
  Kernel driver in use: i915

starfall@nx ~ $ uname -a
Linux nx 4.3.0-040300-generic #201511020846 SMP Mon Nov 2 13:48:04 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

starfall@nx ~ $ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.3.0-040300-generic root=UUID=2210e25b-435d-431e-a001-2707f532d714 ro quiet splash i915.preliminary_hw_support=1 vt.handoff=7
3

I found that DP and not HDMI works if you have a late kernel, 4.3 or so, and no nomodeset.

This is a minor bug that I'm sure will be fixed as time goes by and Skylake becomes popular.

I don't use an external video card, just integrated Intel.

frank@flash:~$ inxi -b
System:    Host: flash Kernel: 4.4.0-040400rc5-generic x86_64 (64 bit)
           Desktop: Unity 7.4.0  Distro: Ubuntu 16.04 xenial
Machine:   Mobo: ASRock model: Z170 Gaming-ITX/ac
           Bios: American Megatrends v: P1.50 date: 11/04/2015
CPU:       Dual core Intel Core i3-6100 (-HT-MCP-) speed/max: 799/3700 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics
           Display Server: X.Org 1.17.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 2560x1440@59.95hz
           GLX Renderer: Mesa DRI Intel Skylake DT GT2
           GLX Version: 3.0 Mesa 11.0.7
Network:   Card-1: Intel Ethernet Connection (2) I219-V driver: e1000e
           Card-2: Broadcom BCM4352 802.11ac Wireless Network Adapter
           driver: bcma-pci-bridge
Drives:    HDD Total Size: 756.2GB (32.1% used)
Info:      Processes: 250 Uptime: 1 min Memory: 615.2/15736.5MB
           Client: Shell (bash) inxi: 2.2.28 
3

Installing Linux Mint 17.3 Rosa solved it!

Somehow, Mint 17.3 enabled i915_bpo driver automatically. Here's lshw output:

    *-display
         description: VGA compatible controller
         product: Intel Corporation
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 06
         width: 64 bits`
         clock: 33MHz
         capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
         configuration: driver=i915_bpo latency=0

If you're still running 17.2, you might have some luck with trying to install i915_bpo manually.

1

Those affected should boot up to a 16.04 live using latest daily and see how Intel works -

http://cdimage.ubuntu.com/daily-live/current/

Works just fine here with Skylake (520)

If Intel is fine then nvidia should be good on Desktops but tearing will be rampant on nvidia-prime/optimus.

In that case the only decision is whether to go to 16.04 now or later. I'd go for now as 15.04/15.10 are just point in time 'releases' with a modicum of late day bug fixes & such;

1

I'm on msi gs40 6qe with i7 6700hq.

  • Intel HD 530: i915.preliminary_hw_support=1 and blacklisting nouveau got xorg to start. Tested with 4.1.13lts, 4.1.15lts, 4.2.5, 4.3, 4.4.0-rc4-gb9d845, 4.4.0-rc5. But here's the sad part: after 5s-2hours of using it freezes, sometimes I'm able to kill xorg which give a few more time, sometimes laptops hangs with it (nothing works, even tty switching doesn't).
  • GTX 970 I tried Optimus and Prime, none of this works.
    • Optimus produces a black screen without backlight, but xorg starts (I have skype on system startup and I've heard it sound).
    • Prime fails to read DRM and doesn't start at all.

Also please take a look at mine topic on forum.

  • If you read this report carefully it may be your issue with nvidia, ie. actually everything works fine Except no visible display. If the display is put to sleep, then woken you'll get a display for the rest of session. bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/… In 15.10 a "workaround" 'fixes ' the above issue as seen here in a wrong reason report - bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/… – doug Dec 13 '15 at 0:33
  • Anyway I get glib stacktraces with nvidia. Since both nvidia and nouveau require integrated graphics to forward the image on a screen. (xorg driver in case of nvidia and intel driver in case of nouveau). Without proper kernel skylake support it won't work( – deathangel908 Dec 13 '15 at 0:39
1

As long I turn on two screens (Menu System Settings -> Display), one with Displayport, the other on HDMI, my Ubuntu 15.10 is very stable. I don't use nomodeset or other tweaks, no special kernel versions, etc.

If I turn off one of them, I get freezes again.

Intel i-6670 on Asus Z170 Pro Gaming with Intel HD 530.

I would suggest to upgrade to kernel 4.4.1-040401-generic.

1

G'Day folks.. Luckily with the pickup in Linux/Ubuntu recently you can just use the new Intel Graphics installer located at the Intel website:

https://01.org/linuxgraphics/downloads/intel-graphics-installer-linux-1.4.0

It fixed all my weird graphics issues on my new Dell XPS 13 (9350) so everything is now working :)

  • Black screen after grub boot screen (added i915.modeset=0 to grub conf to boot successfully - Removed after graphics driver update)

  • xrandr would error out on the output

  • Graphics glitches like lightdm semi-crashing the desktop

  • Couldn't add the second monitor tyo the existing x config (Even with dpkg-reconfigure xserver-xorg)

This does need a kernel 4.3 > so you may need to upgrade, I believe the website I posted has links to everything you need to install the driver so you should be good to go..

  • Movies are now smooth at full screen (I was dropping FPS like it was going out of fashion. (more displays than in the config then bombed out)

Good luck trend setters..

  • Does it work for Linux Mint? Last time I tried, it didn't – Denis Gorbachev Mar 21 '16 at 18:11
  • Of course, Mint is 14.04 based for the moment. – RoundDuckMan Mar 26 '16 at 18:50
1

Got mine working, I am on Asrock Z170 EXTREME6 i7-6700K onboard gfx only.

tnc***@***tnc17:~$ sudo lspci -k | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
    Subsystem: ASRock Incorporation Device 1912
    Kernel driver in use: i915

Ubuntu 15.10 x86_64

4.3.0-040300-generic #201511020949

This link should solve your issues.

"Intel GFX Repo/Installer"

Feel free to shoot me a msg I will help if I can, but its pretty strait forward.

1

I'm on msi gs70 6qe with i7 6700hq and GTX 970M.

With Ubuntu 16.04 LTS installer USB stick, using UEFI, I've finally booted successfully !

The only boot parameter I've set after the "splash" parameter was "nouveau.modeset=0".

To me the Intel HD 530 works fine but not the NVIDIA GTX 970, which freezes Ubuntu's boot process. Probably a NVIDIA firmware will need to be added/uploaded to avoid boot freeze.

1

If you have problem that cannot boot ubuntu even from live usb, you should try first

  1. set nouveau.modeset=0 (press e when ubuntu first restart, when you are choosing list of OS. Then add argument nouvea.modeset=0 after quite splash)add argument nouveau.modeset=0 after quite splash
  2. if the first one does not work, then try set nomodeset instead of nouveau.modeset=0 (add nomodeset after quite splash)

NOTE:

  • We ONLY use nomodeset temporary, don't change it in grub default (don't add nomodeset in this file /etc/default/grub) after booting ubuntu with nomodeset, install any driver you want from additional driver or from .deb package. then restart the ubuntu.

  • Setting nomodeset after install nvidia will create the loop login or crash the ubuntu-control-center

If working well, then add the nouveau.modeset=0 in default of grub, run some commands in this link How do I set 'nomodeset' after I've already installed Ubuntu?

protected by Community Aug 24 '18 at 11:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.