How do I manage (add/remove) all the startup applications in Ubuntu 11.10 and up?

Startup Applications doesn't show all the applications which are started during boot.

  • Your link not work. I have tried all answer but .. not work
    – user8324
    Jun 18, 2012 at 7:32
  • 3
    Are you using Ubuntu 12.04.
    – atenz
    Jun 18, 2012 at 7:36
  • 1
    @tijybba yes. I am using 12.04. However, after restarting, I can see list of programs. Thanks . This question is dublicate. Please give vote to close .
    – user8324
    Jun 18, 2012 at 7:39
  • 2
    Okey-Dokey , so please Up-vote my comment :D :)
    – atenz
    Jun 18, 2012 at 7:42

5 Answers 5


As said above, you have to edit /etc/xdg/autostart/ and either:

  • remove the NoDisplay=true lines;
  • or make those same lines comments by adding # in front of them;
  • or replace true by false in those same lines.

The third solution can be easily done in three steps:

  1. Summon the terminal with Ctrl + Alt + T.
  2. Type the two following commands:

    cd /etc/xdg/autostart/
    sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

After changing anything you want, you can go back to the previous state by typing this into the terminal:

sudo sed --in-place 's/NoDisplay=false/NoDisplay=true/g' *.desktop

This has been tested in 12.04, 12.10 and 13.04.

[Source: iloveubuntu.net, thank you Nikhil Sinha for the link]

  • how can you disable them if you do not have root access? these start gnome apps for KDE which I don't want Nov 22, 2012 at 1:20
  • Can also be found here help.ubuntu.com/community/ShowHiddenStartupApplications
    – Stan
    Dec 30, 2013 at 19:23
  • The first suggestion has worked for me. I just cd /etc/exdg/autostart and removed the program I wanted to remove from the autostart directory. You can view autostart programs by run ls and from the list you can see the application or program you want to remove. Mar 12, 2017 at 20:32
  • if you edit /etc/xdg/autostart/ be aware, that you should undo those changes before you upgrade your system, otherwise you will get a question if you want to keep the edited .desktop files or use the package maintainers default for each of those files! A better solution is to create files in ~/.config/autostart/ as suggested in @TormodVolden 's answer
    – rubo77
    Oct 28, 2019 at 7:14

Remove the NoDisplay=true line from each entry in /etc/xdg/autostart/ Then just uncheck the ones you don't want in Startup Applications. Generally though the autostart apps are there for a reason so make sure you know what you're doing when you disable them.

There are also various services which store their configuration files in /etc/init. Most users shouldn't touch those files though.

  • Jeremy - Thanks for the tip. BTW, used BUM (bootup-manager) to disable many of the services which I don't use and shaved the boot time. I liked Ubuntu, but 11.10 ignored some basic things, like adding users to groups from UI, screen savers, easily modifying unity launcher icons. I am not a big fan of UI, but a UI will easily get more people on-board. Oct 21, 2011 at 1:08

The correct way to do this as a normal user is to copy the desktop file in question from /etc/xdg/autostart/ to ~/.config/autostart/ (create the directory first if needed) and edit this copy to state NoDisplay=false. Then open "Startup Applications Preferences" and uncheck the corresponding box.

Now you need to remove the NoDisplay=true key from the files after copying them, which can be done with sed for all of them with

sed -i '/NoDisplay=true/s/^/#/' ~/.config/autostart/*.desktop
  • 2
    You still need to remove the NoDisplay=true key from the files after copying them, which can be done with sed -i '/NoDisplay=true/s/^/#/' ~/.config/autostart/*.desktop. Jun 21, 2017 at 8:35
  • 1
    I think this is the best way to do this, because it will ensure that changes are persisted even when the application updates.
    – kapad
    Apr 27, 2019 at 14:24
  • remember to check the files in ~/.config/autostart/ after a system upgrade for any changes compared to the default files in /etc/xdg/autostart/ in case something was added during upgrade
    – rubo77
    Oct 28, 2019 at 7:49

It's normal that you don't see anything listed. The Additional startup programs list is just for programs that start up for the current user (not necessarily for other users, and not all the services that start when Ubuntu boots). Furthermore, it doesn't list the normal parts of the desktop environment that start when the user logs in graphically.

You can check here

Anyone can check this by clicking "Startup applications". Its blank by default.

enter image description here

If you want to have the hidden startup entries shown (such as update notifier, orca screen reader, onboard, etc), just type/copy and paste the following in a terminal:

find /etc/xdg/autostart ~/.config/autostart -name \*.desktop -exec sudo sed –i -e '/^NoDisplay=/d' {} +

If you want to hide the normally hidden entries, just type/copy and paste the following

echo NoDisplay=true | find /etc/xdg/autostart ~/.config/autostart -name \*.desktop -exec sudo tee -a {} + >/dev/null

Source: How-To Geek

  • when I click to program, it shows nothing .
    – user8324
    Jun 18, 2012 at 7:37
  • Yeah its blank by default.
    – BigSack
    Jun 18, 2012 at 7:44
  • 9
    I recommend you delete this answer, @BigGenius -- the OP knows its blank which is why he's asking us :)
    – ish
    Jun 18, 2012 at 7:47
  • If you read above comment. They are also doubt if its blank or populated by default.
    – BigSack
    Jun 18, 2012 at 7:53
  • I think BigGenius is right. There are no StartUp programs enabled by default so the list is blank.
    – upapilot
    Jun 18, 2012 at 8:02

An alternative:

To view all startup applications at "startup applications" just open /etc/xdg/autostart and modifying the line NoDisplay=true to #NoDisplay=true. Just add an # . Then you will be able to see all at "startup applications" and disable what you want from there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .