Because I'd like to use the Gedit LaTeX plugin that is unfortunately not available for Gedit 3.2 in the repositories, I want to compile it myself. The most recent version you can get on http://git.gnome.org/browse/gedit-latex does support GNOME 3 's Gedit.

In the documentation it says:

Due to a limitation on reading Settings, the plugin currently must be installed in the same prefix as gedit. For instance if you are using gedit 3 from your distribution, you need to do

./configure --prefix=/usr make sudo make install

If you are using a 64bit distribution, you also need to pass --libdir=/usr/lib64 to ./configure script.

That's why I cded into the directory that contains the code, and tried to run ./configure --prefix=/usr --libdir=/usr/lib64. Unfortunately, this does not work, giving the error message:

bash: ./configure: No such file or directory

Having checked the folder, there indeed is no file configure, but only configure.ac. What can I do to compile this plugin?

  • 1
    just install this package -> apt-get install autopoint and execute autogen.sh again.....
    – hhlp
    Oct 20, 2011 at 18:22

2 Answers 2

  1. Library necessaries to build the configuration files

    sudo apt-get install intltool libtool
  2. Dependency necessary to compile this plug-ins

    sudo apt-get install gedit-dev
  3. Build the configuration file

    touch config.rpath
  4. Configure and compile

    ./configure --prefix=/usr
    sudo make install

If you are using a 64bit distribution, you also need to pass --libdir=/usr/lib64 to ./configure script.

    ./configure --prefix=/usr --libdir=/usr/lib64

With a 64bit distribution, I also had to create two symbolic links, otherwise the plugin would not show up:

sudo ln -s /usr/lib64/gedit/plugins/latex.plugin /usr/lib/gedit/plugins/
sudo ln -s /usr/lib64/gedit/plugins/latex /usr/lib/gedit/plugins/
  • hhlp, thanks a lot! However, touch config.rpath ./autogen.sh gives an error, could you check my question again? I put the message there. Thanks a lot!!
    – Ingo
    Oct 20, 2011 at 18:17
  • Whatever, now it works....
    – Ingo
    Oct 20, 2011 at 18:23

Assuming you are using Ubuntu Oneiric 64-bit, you have to download and extract this http://ftp.gnome.org/pub/GNOME/sources/gedit-latex/3.2/gedit-latex-3.2.1.tar.bz2. The intltool and libgtk-dev packages are needed, so you have to install them

sudo apt-get install intltool libgtk-3-dev

Once you've done that, cd into the directory gedit-latex-3.2.1 you extracted and run

./configure --prefix=/usr --libdir=/usr/lib64
sudo make install

And everything should be fine.

P.S. The LaTeX plugin uses rubber by default, so if you are not changing the compilation tools that are already there you should install (or check if installed) the packages: rubber, python-poppler, python-glade2, python-enchant and texlive.

  • package libgtk-dev doesn't exit in any ubuntu version -> packages.ubuntu.com/…
    – hhlp
    Oct 20, 2011 at 17:19
  • 1
    It was libgtk-3-dev, I didn't notice the typo, but I already changed it. Thank you for pointing that out. Oct 20, 2011 at 17:41
  • Thanks for your answer, but it doesn't seem to work because you're missing the step touch config.rpath ./autogen.sh. But nevermind, because that one doesn't work either ;).
    – Ingo
    Oct 20, 2011 at 18:16
  • I tried it like described (using and extracting the package in the link I provided) and everithing worked. Well, good luck anyway! :) Oct 20, 2011 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .