3

I just installed Ubuntu 14.04.1 on my computer:


     mohsen@Bob:~$ uname -a
     Linux Bob 3.19.0-33-generic #38~14.04.1-Ubuntu SMP Fri Nov 6 
     18:17:28 UTC  2015 x86_64 x86_64 x86_64 GNU/Linux

But I cannot install skype on it. I am getting the following error. I assume that I am missing some dependencies.


     mohsen@Bob:~$ sudo apt-get install skype
     Reading package lists... Done
     Building dependency tree       
     Reading state information... Done
     Some packages could not be installed. This may mean that you have
     requested an impossible situation or if you are using the unstable
     distribution that some required packages have not yet been created
     or been moved out of Incoming.
     The following information may help to resolve the situation:
     The following packages have unmet dependencies:

     libgl1-mesa-glx : Depends: libudev1 but it is not going to be installed or
                                libudev0 but it is not installable
     skype : Depends: skype-bin
     E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I tried to follow the steps in the following link:

How to install Skype 4.3?

but when I type

      sudo apt-get install sni-qt:i386 

I get the following error:


      mohsen@Bob:~$ sudo apt-get remove skype skype-bin:i386 skype:i386
      Reading package lists... Done
      Building dependency tree       
      Reading state information... Done
      Package 'skype' is not installed, so not removed
      Package 'skype:i386' is not installed, so not removed
      Package 'skype-bin:i386' is not installed, so not removed
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      mohsen@Bob:~$ sudo apt-get install sni-qt:i386
      Reading package lists... Done
      Building dependency tree       
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:

      The following packages have unmet dependencies:
      sni-qt:i386 : Depends: libc6:i386 (>= 2.2) but it is not going to be installed
           Depends: libdbusmenu-qt2:i386 (>= 0.3.2) but it is not going to be installed
           Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
           Depends: libqt4-dbus:i386 (>= 4:4.6.1) but it is not going to be installed
           Depends: libqtcore4:i386 (>= 4:4.7.3-1ubuntu3~) but it is not going to be installed
           Depends: libqtgui4:i386 (>= 4:4.7.3) but it is not going to be installed
           Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed
       E: Unable to correct problems, you have held broken packages.

Any thoughts on why this is happening? How can I install skype?

3
  • Run sudo apt-get install -f. You might also want to try downloading the DEB from the website and using that. – TheWanderer Nov 14 '15 at 22:33
  • 1
    Edit your question and add the output of apt-cache policy sni-qt:i386 libc6:i386 – A.B. Nov 17 '15 at 7:30
  • 1
    And the output of dpkg --print-foreign-architectures – A.B. Nov 17 '15 at 7:32
6

Please enable Canonical Partner repositories via System Settings > Software Update > Other Software reload the sources and then install skype via your software center.

6
  • libc6 all other not-installable libraries are NOT in the Partner repository, why should your answer help? – A.B. Nov 17 '15 at 7:38
  • 1
    Anyways, tried to help you and you downvote me, not nice. Next time good luck in asking help here or anywhere. From 10.04LTS, Cannonical has packaged Skype via partner repository and installing it either in x32 or x64 has never ever been an issue. Only those who don't go through wiki or instructions try and install it via download and thats where all these issues start. – Arup Roy Chowdhury Nov 17 '15 at 8:01
  • 2
    OK, +1 for the motivation, perhaps you're right. – A.B. Nov 17 '15 at 10:19
  • 1
    @ArupRoyChowdhury If it helps, it's great and simple. I never had any issues with skype as well and always enable the partner repo. And another tip from me: Please don't take the voting stuff here too serious. It's all about content, never personally. If somebody thinks your answer is wrong, he downvotes. Maybe that user is wrong and he undoes it if he realizes. Anyway, don't let a bad vote destroy your motivation to help others, improve the Ubuntu community and make the internet a better place to find information and help! Thanks :-) – Byte Commander Nov 17 '15 at 10:30
  • 1
    @Byte Commander, thanks. many new users tend to get wrong advice and download Skype and install and that can lead to lots of issues, always safer via Ubuntu repository. – Arup Roy Chowdhury Nov 17 '15 at 11:05
4

Run these commands:

sudo dpkg --add-architecture i386
sudo apt-get update

That should make it possible to install the 32 bits packages, which Skype requires.

2

Download Skype from the official website and manually install it with the following commands.

  • Download Skype:

    wget http://download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
    
  • And then install it:

    sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.