1

System specs:

Ubuntu 15.04, Dell Inspiron

Graphic drivers:

  1. Intel Corporation 3rd Gen Core processor Graphics Controller
  2. NVIDIA Corporation GK107M [GeForce GT 640M]

Monitor: BenQ EW2440

What I am trying to do?

Connecting my laptop to the BenQ monitor to extend desktop space. The cable that I have used is HDMI at both ends due to the fact that my laptop has no VGA port.

What I have tried?

  1. Successfully installed Intel Graphics Controller via this link https://01.org/linuxgraphics/downloads I have installed the drivers using Intel Graphics Installer for Linux* 1.2.0

  2. Tried installing Nvidia proprietary driver via 'Additional Drivers' System fail to boot into GUI. Check error in /var/log/Xorg.0.log and it says "nvidia" screen is not configured. Tried adding "nvidia" configuration as below

    Section "Device"
        Identifier "nvidia"
        Driver "nvidia"
        BusID  "PCI:2:0:0"
    EndSection

    Section "Screen"
        Identifier "nvidia"
        Device "nvidia"
    EndSection

but everytime on reboot, xorg.conf is reset back. Tried the solution in this link http://ubuntuforums.org/showthread.php?t=2220552 by commenting inside the gpu-manager.conf as apparently, gpu-manager might be overwriting the file. However, even after commenting out, it is the same.

  1. Reverted back to Nouveau driver and checked System Settings->Displays. It does show the BenQ monitor. However, the monitor is blank. Image as below.

System settings -> Display

Output of running xrandr in console

Screen 0: minimum 8 x 8, current 3046 x 1050, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1366x768       60.1*+   40.0  
   1360x768       59.8     60.0  
   1280x720       60.0  
   1024x768       60.0  
   1024x576       60.0  
   960x540        60.0  
   800x600        60.3     56.2  
   864x486        60.0  
   640x480        59.9  
   720x405        60.0  
   680x384        60.0  
   640x360        60.0  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1680x1050+1366+0 (normal left inverted right x axis y axis) 531mm x 298mm
   1920x1080      60.0 +   50.0     59.9  
   1920x1080i     60.1     50.0     60.0  
   1680x1050      59.9* 
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1280x800       59.9  
   1152x864       75.0  
   1280x720       60.0     50.0     59.9  
   1024x768       75.1     60.0  
   832x624        74.6  
   800x600        75.0     60.3  
   720x576        50.0  
   720x576i       50.1  
   720x480        60.0     59.9  
   720x480i       60.1     60.1  
   640x480        75.0     60.0     59.9  
   720x400        70.1  
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

If you need further details, let me know. Any help is greatly appreciated.

0

Try 1920x1080i or 1280x720 on the BenQ monitor. I've got BenQ monitor too (different model) and the highest resolution simply does not work. I suspect there is problem in the EDID.

Your system has 2 GPUs which indicates Optimus technology and the displays are most likely connected to the Intel gpu. Then you don't use xorg.conf but bumblebee package to make use of nvidia rendering power.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.