1

To drag something with the mouse, it seems I have to hold the mouse button down for a fraction of a second before dragging (dragging immediately after clicking does not work).

I don't like this, but can't find any setting in the 'mouse & touchpad' settings to change it. Is there any way to reduce this delay?

1

I have the same problem, though it seems to come and go, depending on system updates from Canonical.

Interestingly, it was happening earlier to me until I plugged in an external USB mouse to test with. Now things are working perfectly, even when I remove the external USB mouse. By the way, my system is a Dell Vostro 2420 laptop with a trackpad.

| improve this answer | |
1

And now it's back again, at least with the trackpad. External USB mouse works fine when I plug it in. It seemed to go bad after I did a two-finger click-drag to scroll with the trackpad.

| improve this answer | |
1

The solution that's worked for me is toggling the input device on and off.

First you find the input device that's misbehaving:

foo@machine:$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=12   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=13   [slave  keyboard (3)]

Then you toggle that ID on and off, for me it's always been the Synaptics TouchPad (ID=11):

foo@machine:$ xinput set-prop 11 "Device Enabled" 0
foo@machine:$ xinput set-prop 11 "Device Enabled" 1

And now its all working again, I think this is definitely a bug. I've randomly observed it across 3 different laptops, but haven't had the change to debug it.

| improve this answer | |
  • This worked for me - thanks! (On openSUSE, in fact.) Yes, agree it definitely looks like a bug. – Adam Spiers Apr 19 '19 at 23:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.