0

My computer had Windows 8 previously. Then I installed Ubuntu 14.04LTS. Until few days ago Grub loader was showing and every thing was normal. But now it's straightly boots Windows. But when I go to Boot device options in Startup menu I can see OS boot manager and Ubuntu(.....Hard disk) From there I can select Ubuntu and the Grub loader will show up next. But every time I have to do that. I don't know what happened. I tried the Legacy boot option too. But still the problem is unsolved. Hope you have the answer...

0

I could be mistaken but I believe this is the direct result of a "Windows Update" which prohibits any operating systems other than Windows to boot your computer. I blogged about this on google plus last month, and at the time I was in disbelief until one of my readers replied with this most informative link.

It was my first impression that only windows 10 did this to computer but now it appears that previous supported versions of windows receive an update which sabotages your hardware. I've also determined that older hardware is immune to this "feature" so until there is a class action suit against Microsoft for this MONOPOLISTIC, and most underhanded move, you can continue to enjoy dual booting but you must use an older laptop, either that or a new desktop built from quality generic components such as my ASUS here.

  • No. I didn't update my computer through Windows. Auto update is turned off. But I did install Windows 10 and downgraded it to Windows 8 again. But that was before the installation of Linux. Still is it possible the same issue has occurred? – Vickey Nov 14 '15 at 6:30
  • This and other reputable web articles insist that windows has been installing "important security updates" without your knowledge and consent. What could be more important than prohibiting you from booting to a competing operating system?: securitywatch.pcmag.com/security-software/… – gyropyge Nov 14 '15 at 21:15
0

Boot into Ubuntu and run these commands.

sudo grub-install /dev/sda

Reinstalls the boot loader.

and

sudo update-grub /dev/sda

scans for boot able operating systems and adds them to the boot menu

This might fix the problem if it dose not you may need to add Windows 8 to the boot loader manually.

You will need to edit:

sudo nano /etc/grub.d/40_custom

and add something like this

#/etc/grub.d/40_custom
menuentry "Windows 8 (loader) (on /dev/sda3)" {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos3)'
chainloader +1
}

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.