4

I've had both Ubuntu 14.04 and now 15.10 installed on my laptop and both have caused overheating issues with my laptop.

Temperature reach above 80 degrees celsius within the first 20 minutes of very light use (I use the laptop for University so usually only VIM, terminal and maybe a couple of tabs open in Firefox).

I have tried powertop which seemed to slow down the overheating but it still reaches 80 degrees quite easily. I have also tried CPUFreq which really hasn't done much. I have also tried using proprietary drivers as well as both legacy and binary drivers for the graphics card (which is a Nvidia GeForce 620M).

This is a screen shot of psensor: PSensor

This was just from general use. I cannot watch online lectures because it overheats so much that everything seems to run at 5 FPS and this happens with any sort of video playback service. I should also mention that the fans go crazy (very loud compared to any laptop I have heard) so I don't think it is a fan control issue.

Laptop: Acer Aspire V5-571PG-53314G75Mass

These problems have been here since I installed Ubuntu. It was running Windows very well. I had no overheating issues at all and the battery performance was 4 times as much as it is now on Ubuntu.

How can I prevent this from happening?

  • 2
    What type of laptop? – Alex Lowe Nov 14 '15 at 4:14
  • 1
    To expand that, type, brand, age, model number, and did any mjaor changes take place that this started? – David Nov 14 '15 at 4:15
  • I have updated the question to include more information. – ReallyGoodPie Nov 14 '15 at 4:29
0

Perhaps you should install thermald and see if this helps. Thermald will use available passive thermal controls to try and reduce overheating.

  • 1
    Thermald is installed by default on Ubuntu 15.10. – ReallyGoodPie Nov 14 '15 at 5:53
0

I don't think your laptop is overheating.

Your CPU's max operating temperature is 105 °C

There is nothing to worry about if your CPU runs at 75 °C since it's still under the safe operating temperature as stated Here

Your GPU running at 69 °C is an excellent temp to be running at according to this GeForce forum.

If you want to make your fan spin faster you can try fancontrol.

To install fancontrol run this command:

sudo apt-get install fancontrol

Great post here on how to setup fancontrol on Ubuntu

If your laptop is still hot, you may need to clean the dust out of the vents.

  • This was after 20 minutes of normal use. If I do anything remotely intensive, such as watch a TV show only (1/2 hour), it reaches the 95-100 degree mark quite easily and lags the whole computer to the point where it is unusable. I am unable to take screen shots when this happens because it takes so long for anything to respond. Under normal operations, the laptop gets really hot almost to the point of it burning you when you touch it. My fans are also extremely loud compared to when it was running Windows. I am sure they are running at full speed but I will give this a go. – ReallyGoodPie Nov 14 '15 at 5:14
  • @ReallyGoodPie let me know if fancontrol works for you. – Neil Nov 14 '15 at 6:02
  • Can't get pwmconfig to work. I have tried several troubleshooting guides but it still returns /usr/bin/pwmconfig: There are no pwm-capable sensor modules installed – ReallyGoodPie Nov 14 '15 at 6:35
  • @ReallyGoodPie did you follow this post ? it looks like PWM control is not supported on your Motherboard. you may want to check the bios setting sometimes there is a fan speed setting. like quiet normal performance. – Neil Nov 14 '15 at 7:01
  • @ReallyGoodPie Laptops with a dedicated GPU can get really hot because is shares the heat sink with the CPU, my advise would be clean the vent fans, and reapply the thermal grease on the CPU and GPU. – Neil Nov 14 '15 at 7:07
0

The problem is because the system is not using the correct graphical services as you video card driver, it is using the Processor Recurses so The mainboard starst to overheating.

I'm not sure why the people of ubuntu doesn't include as a default bumblebeed.

So you just have to install it:

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic

Restart, go to System Configuration->Sotware Updates-> Aditonal Controls

Aditonal Controls

and select the NVIDIA driver(these controllers are privative) you can try all of them to see wich one is the best so you can have the amazing 55°C temperature I have.

You can find the oficial documentation here

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.