3

Question

I am installing a LEMP stack on a fresh minimal install of Ubuntu 14.04 LTS.

When I tried to install MySql

sudo apt-get install mysql-server

it returned an error with the following explanation:

mysql-server depends on mysql-server-5.5; however:
Package mysql-server-5.5 is not configured yet.

How do I solve this problem?

What I have read

This question is very similar to Upgrade MySQL server issue, however, that question was (incorrectly, I believe) marked as a duplicate of this question. None of the answers to these two questions solved my problem.

I have also seen E: Mysql-server-5.5 Installation Error. This question was closed for being unreproducible. However, I can reproduce my problem every time I try to install mysql server on a fresh minimal installation of Ubuntu 14.04 (the key word being minimal).

Purpose of this question

I finally solved my problem, but I could not add an answer to any of the questions I linked to above, so I am creating a new question here so that I can answer it myself.

2

The main problem is that the minimal Ubuntu install does not have everything that you need.

The post Package mysql-server-5.5 is not configured yet provides the solution to your problem. I suggest you read that. However, I will provide a brief summary below.

Clean out the old mysql installation.

sudo apt-get purge mysql*
sudo apt-get autoremove
sudo apt-get autoclean

Upgrade the things that are missing in the minimal Ubuntu installation.

sudo apt-get dist-upgrade

Install MySql as normal:

sudo apt-get install mysql-server

If that still doesn't work you can do

 sudo apt-get install mysql-server --fix-missing --fix-broken
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.