2

I just updated to weazel/15.10 and have noticed some strange behavior with my volume control (master, in the notification tray/bar).

While it lists controls for various sound emitting programs when I click on it, adjusting the slider has NO effect on volume.

I found that opening the sound settings in the control center, adjusting the slider there will adjust sound for THAT output device. But, is there no longer a master control volume? Or does the notification tray icon for speaker not default to the volume levels for the active output device?

googling returned very little, AskUbuntu had a few that appeared worth a look but thus far haven't seemed applicable

  1. Volume slider only change the Master volume, not PCM
  2. How do I change the way Ubuntu adjusts my volume mixer levels?
  3. How to switch 'default' sound device controlled by hardware keys in Xubuntu?
  4. https://superuser.com/questions/594154/prevent-applications-to-control-master-volume-on-linux
  5. How to switch 'default' sound device controlled by hardware keys in Xubuntu?

This one especially looked useful, but was closed/unanswered... Master volume versus application volume

EDIT: Interestingly, I tried opening the sound settings via cmd (to create an easy repo of the problem)... unity-control-center --name=sound

...then was given the following output in the terminal window...
(sound:31965): sound-cc-panel-WARNING **: Unable to find stream for bar '(null)'

(sound:31965): sound-cc-panel-WARNING **: active_output_update - couldn't find a stream from the supposed active output

(sound:31965): sound-cc-panel-WARNING **: active_input_update - couldn't find a stream from the supposed active input

I then noticed the volume control was now gone.

I then went and opened the sound settings via the main settings panel, and the volume control reappeared in the tray.

Now adjusting it controls the master volume. Bizarre, perhaps there was something that didn't quite survive the transition to the upgrade to wiley-weazel/15.10 and it was reset.

Leaving this in case anyone else has the same problem

  • Have you tried running the command: alsamixer in a terminal? You may be able to control the volume using these controls which may be necessary when using an XFCE type desktop. – mchid Nov 14 '15 at 1:47
  • I didn't try that, like I said, I was able to control sound levels for individual output devices from the system settings dialog. The problem has resolved (somehow) after trying to open the system settings dialog from the terminal – t.j. Nov 17 '15 at 16:46
  • askubuntu.com/questions/591371/… provides a tip that may be useful in this case: "in Volume Control - Output Devices tab i clicked on the green icon 'Set As Fallback' next to the bluetooth device and that did it" – Bengt Olsson Mar 6 '16 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.