1

I am currently using Ubuntu 15.10 and wanted to try out Gnome 3.18. Everything worked, but finally I wanted to switch back to Unity, because I like it more. Since I remove all the Gnome 3 packages, my nautilus file manager looks and behaves strange. E.g. previously the "Instant-search" option was turned off which is now turned on, the corner of the window are not round but filled small black edges and the sidebar looks not right, too.

Here is a screenshot:

enter image description here

Is there any easy way to restore the default appearance and settings of nautilus?

I tried the obvious stuff, such as apt-get purge nautilus, apt-get install nautilus --reinstall and deleting .config/nautilus but nothing worked.

Thanks for you help

  • Try a sudo apt-get install nautilus --reinstall – David Nov 13 '15 at 21:02
  • 1
    Try deleting the ~/.config/nautilus directory. – errikos Nov 13 '15 at 21:19
  • Both tips did not help. Still the same issue as before. I will add that to my original question. – whoww Nov 14 '15 at 13:29
  • I think you have "leftovers" from Gnome packages. Especially that shadow thing around the window is a Gnome thing. I don't know how to help though. – errikos Nov 14 '15 at 14:16
  • That what I thought, too :( – whoww Nov 16 '15 at 13:59
0

Although it's been some time since the OP asked the question, this is still relevant as I've faced the same situation recently after finishing experimenting with the Gnome3 PPA on my 16.04 system. Updating with this PPA resulted in Nautilus and a few other packages being upgraded (the OP's screenshot shows Nautilus 3.18, which is what I was upgraded to).

In my case, I checked my /var/log/dpkg.log (grep for "status installed" to make scanning easier) to identify the packages I had upgraded from the PPA. These were:

  • libnautilus-extension1a
  • nautilus-data
  • nautilus
  • libgnome-bluetooth13
  • gnome-bluetooth

Your particular case may vary, but for the purposes of restoring Nautilus the first three packages were the ones I needed to downgrade.

After removing the Gnome3 PPA, I used apt-cache policy to verify for each of the three nautilus packages the installed version and the repository version (the one I wanted to downgrade back to), e.g.:

$ apt-cache policy libnautilus-extension1a
libnautilus-extension1a:
  Installed: 1:3.18.5-0ubuntu1~xenial1
  Candidate: 1:3.18.5-0ubuntu1~xenial1
  Version table:
 *** 1:3.18.5-0ubuntu1~xenial1 100
        100 /var/lib/dpkg/status
     1:3.18.4.is.3.14.3-0ubuntu5 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     1:3.18.4.is.3.14.3-0ubuntu4 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

For my 16.04 system, I needed to downgrade from the PPA's "1:3.18.5-0ubuntu1~xenial1" back down to "1:3.18.4.is.3.14.3-0ubuntu5". For anyone still on 15.10, the applicable version is "1:3.14.2-0ubuntu13".

Apt allows you to downgrade packages to specific versions, by following the package name with an equals sign (see man apt for details). apt install --reinstall didn't work for the OP as that is not the correct syntax to tell apt to downgrade. In my case, I was able to successfully downgrade Nautilus using:

sudo apt install libnautilus-extension1a=1:3.18.4.is.3.14.3-0ubuntu5 nautilus-data=1:3.18.4.is.3.14.3-0ubuntu5 nautilus=1:3.18.4.is.3.14.3-0ubuntu5 

If you don't do all three packages, you'll have problems such as nautilus not starting, as the 3.18 Gsettings schema lacks some keys that are in the 3.14 schema. Gsettings/dconf is where critical configuration is kept for Nautilus and various other apps; ~/.config/nautilus has some settings, but not all.

0

Disclaimer: I tried this on my ubuntu 17.04 but don't know if this works on 15.10. (I don't even know whether 15.10 uses dconf or gconf.)

In ubuntu 17.04, you can do this with dconf.

Most simply, just run gsettings reset-recursively org.gnome.nautilus in a terminal and every nautilus setting will be reset to default. If you want to reset only specific settings, gsettings list-recursively org.gnome.nautilus will give you a list of key-value pairs you can gsetting set or gsetting reset.

Alternatively, if you prefer a GUI editor, install dconf-tools package, run dconf-editor and navigate to /org/gnome/nautilus. Find the relevant keys and right click to reset/customize.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.