10

Remmina had been connecting to my RDP service for several months, until it just stopped. It will still connect by IP address. Ping confirms that the domain name resolves to the proper IP, and nothing has changed on the Windows 7 or 10 machines that use the same pathway. No updates have been recently installed that would account for the change in behavior. I agree that, since my users are up and function I could just ignore this, but it does make me curious as to why, and how to revert to the original functionality.

BTW - I'm new to Ubuntu, but can generally follow detailed instructions fairly well.

Thanks!

6 Answers 6

6

Open Remmina. Right click the malfuntioning connection and click edit. Under the Advanced tab set Security -> RDP.

1
  • Thanks - that works... I have no issues with moving the credential request to after the server connection is established rather than at the beginning of the string, but am curious as to why 'Negotiate' worked so well for so long.
    – mauib0y
    Dec 10, 2015 at 15:21
1

Check ~/.freerdp/known_hosts , you will see such entries

192.1.1.2 68:27:e2:b7:98:f2:98:6e:fa:42:8e:b7:XX:XX:XX:XX:XX:XX

It has Fingerprint along with your IP address which might get expired and new needs to be generated.

and delete the entry having the IP Address you want to connect to. Save the file and connect again.

By deleting and making a connection again, it will create new and it should work

0

Advanced tab, set Security -> TLS worked for me under Ubuntu 14.04, and most recent update of windows 10 as of the time of this post.

0

I am using Ubuntu 14.04. I was having the same issue.

My problem was SSH->Enable SSH Tunnel was enabled.

After uncheck enable ssh tunnel it's working fine.

Remote Desktop Preference

0

I found and deleted two crash files:

./.cache/upstart/update-notifier-crash-_var_crash__usr_bin_remmina.1001.crash.log.1.gz
./.cache/upstart/update-notifier-crash-_var_crash__usr_bin_remmina.1001.crash.log.2.gz

and this allowed me to log in.

0

Under the latest version of Windows 10 and Remmina, you must click on Edit -> Advanced -> Security -> TLS or it may not connect. Also, there is a chance that setting could get reset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .